Ganhe dinheiro  escrevendo tutoriais para o Fórum do BABOO! Conheça os Tutoriais Pagos 2016

Entre para seguir isso  
Seguidores 0
ultimate_live

dica Net Framework 3.5

85 posts neste tópico

Tentei instalar o Net Framework 3.5 e não consegui.

E não é pela web que estou instalando, mas sim usando a versão instalação offline, mas não instala. Tentei em modo de compatibilidade e também não funciona. Nem mesmo o Net Framework 3.5 SP1 instala.

Ambas tenho o instalador offline e não vai. E sem ele instalado eu não consigo rodar alguns programas.

O engraçado é que mesmo que seja um instalador offline, ao iniciar a instalação só aparece a opção: Conectar na net e baixar os arquivos necessários, ou então parar a instalação.

Tentei pela opção: TURN WINDURES FEATURES ON OR OFF e marquei a opção do Net Framework 3.5. Daí confirmei e o windows tentou se conectar ao windows update para baixar os arquivos mas não vai. Sempre dá um erro: 0x800F0906

Se alguém encontrou um problema semelhante, depois de pesquisar encontrei a solução:

Se não vai do jeito normal, então vai de outro.

Segue abaixo como foi feito:

Para ativar o .Net framework 3.5 em maquinas com uma instalação limpa com o Windows 8 Consumer Preview:]

1. crie uma pasta em C: chamada dotnet35

2. Monte a imagem da ISO e copie o conteúdo da pasta \sources\sxs ​para a pasta recém criada, ou use o comando abaixo:

xcopy e:\sources\sxs\*.* c:\dotnet35 /s

3. Execute o comando abaixo no prompt (cmd.exe) com privilégios de administrador:

Dism.exe /online /enable-feature /featurename:NetFX3 /All /Source:c:\dotnet35 /LimitAccess

Problema resolvido.

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá, estou exatamente com essa dificuldade. Não consigo instalar pelo windows update, tampouco pelo instalador offline.

Executando os comandos acima, no meio do processo recebo uma mensagem de erro.

C:\Windows\system32>Dism.exe /online /enable-feature /featurename:NetFX3 /All

ource:c:\dotnet35 /LimitAccess

Ferramenta de Gerenciamento e Manutenção de Imagens de Implantação

Versão: 6.2.9200.16384

Versão da Imagem: 6.2.9200.16384

Habilitando recurso(s)

[===========================65.8%====== ]

Erro: 0x800f081f

Não foi possível localizar os arquivos de origem.

Use a opção "Origem" para especificar o local dos arquivos necessários à resta

ação do recurso. Para saber mais sobre como especificar um local de origem, ve

http://go.microsoft.com/fwlink/?LinkId=243077.

O arquivo de log do DISM pode ser localizado em C:\Windows\Logs\DISM\dism.log

Alguma idéia para resolver a dificuldade?

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Montou a sua imagem ISO antes de executar o comando para copiar o conteúdo ?

Criou a pasta dotnet35 na c: ?

Tem que montar a imagem com o Daemon tools,, Ultraiso ou outro similar.

Depois use o comando cmd (executar como administrador: xcopy e:\sources\sxs\*.* c:\dotnet35 /s (lembrando que aqui o e: é a minha unidade montada).

A sua pasta tem que ter o conteúdo da pastas: sources / sxs

Aqui testei na minha maquina virtual e funciona normalmente.

Talvez tenha errado em algum momento, ou então não copiou todo conteúdo para dotnet35.

Editado por ultimate_live

''

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

No meu Win8 Pro eu apenas habilitei a flag em Recursos do Windows.


Somos quem podemos ser...

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bem. Testei em uma VM, e a dica acima deu certo na versão final também.

robson.sebold, acho que errou em algum momento, ou então não copiou todos os arquivos para que pudesse habilitar o net framework 3.5.

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Aqui consegui instalar normalmente, precisei instalar um programa que pede o NFW e instalei o 3.5 de boa.


gustavopaulinno

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Amigo.

Eu acho que gostou do Avatar que eu criei...

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Oi Ultimate, Estou passando há dias pelo mesmo problema. Essa imagem ISO é do Windows 8? Eu fiz por atualização no site da Microsoft, por isso não tenho a ISO. Tem como enviar o contéudo dessa pasta "sources" para o meu email? agradeço pela dica.

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Me passa o seu e-mail por MP.

Seu Windows 8 é x86 ou x64 ?

Editado por ultimate_live

''

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

é x64

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Já enviei para seu e-mail...

Boa sorte

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Fiz exatamente como falou, mas mesmo assim não deu certo... Provavelmente ó problema é nos arquivos da pasta, seria possível me enviar por e-mail? XXXXXXXXXXXXXX Windows 8 Pro 64bits. Obrigado, fico no aguardo.

Editado por Mr.Million

Remover e-mail. Use MP

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Quer postar a sua dúvida? Cadastre-se pois é rápido e fácil!


Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.


Entrar Agora
Entre para seguir isso  
Seguidores 0
    • 2 Mensagens
    • 249 Visualizações
    • 4 Mensagens
    • 742 Visualizações
    • 3 Mensagens
    • 527 Visualizações
    • 1 Mensagens
    • 466 Visualizações