Jump to content



Foto

EXCEL - Atribuir valor numérico a uma palavra

excel dúvida atributos

Melhor Resposta dignusI, 20 January 2014 - 04:19 PM

Olá Vereda, a fórmula sugerida pelo MARKMZZ acredito que dá certo.

 

Pelo que entendi de sua planilha, quando o aluno "faltou" é necessário não entrar na média.

Dessa forma, utilize essa fórmula:

 

=SOMA(B2:B10)/(CONT.VALORES(B2:B10)-CONT.SE(B2:B10;"faltou"))

 

Abraço.

 

 


LER A RESPOSTA COMPLETA



Existem 8 respostas neste tópico

#1 Vereda    

Vereda
  • Participante
  • 4 mensagens

Publicado 20 January 2014 - 03:33 PM

Olá a todos.

Tenho uma tabela com resultados de provas escolares, onde surge a palavra «desistiu» no lugar de alguns resultados. No entanto, quando faço a média aritmética, apenas são considerados os resultados numéricos. O que eu queria era atribuir 0,0 à palavra «desistiu», fazendo com que a média considerasse também o número de vezes [ou de zeros] que a palavra surge nos resultados.

Será que alguém me sabe ajudar?

Aguardo com enorme expectativa pelas vossas sugestões.

Obrigado.




#2 dignusI    

dignusI
  • Participante
  • 48 mensagens

Publicado 20 January 2014 - 03:40 PM

Olá Vereda, boa tarde!

 

Pensei em duas sugestões:

 

1) Pensando que o intervalo em que estão as notas é de B2 até B10 sugiro o seguinte:

 

Ao invés de simplesmente fazer a fórmula =MÉDIA(B2:B10) faça a média da seguinte fórmula:

 

=SOMA(B2:B10)/CONT.VALORES(B2:B10)

 

Dessa maneira, somamos todas as notas numéricas, e dividimos pelo número de células numéricas ou com o texto desistiu.

 

ou

 

2) Utilizar o CTRL + L, clicar em substituir

 

Localizar os textos «desistiu» e substituir por 0,00.

 

Se não ajudar, se for  possível posta a planilha para nós, no formato "ZIP" (clica com botão direito no arquivo, Enviar para "Pasta Compactada").

 

Aguardamos teu retorno.

 

Abraço.



#3 markmzz    

markmzz
  • Participante
  • 395 mensagens

Publicado 20 January 2014 - 04:00 PM

Olá VEREDA,

 

Faça alguns testes com a seguinte fórmula:

 

=MÉDIAA(B2:B20)

 

e verifique se resolve o seu problema.

 

Markmzz


Editado por markmzz 20 January 2014 - 04:01 PM
''


#4 Vereda    

Vereda
  • Participante
  • 4 mensagens

Publicado 20 January 2014 - 04:11 PM

Olá a todos.

Já tentei com as sugestões que me deram, mas não resultou como eu pretendo.

Segue em anexo um exemplo do problema.

Obrigado pela vossa generosidade.

Arquivos Anexados



#5 dignusI    

dignusI
  • Participante
  • 48 mensagens

Publicado 20 January 2014 - 04:19 PM   Melhor Resposta

Olá Vereda, a fórmula sugerida pelo MARKMZZ acredito que dá certo.

 

Pelo que entendi de sua planilha, quando o aluno "faltou" é necessário não entrar na média.

Dessa forma, utilize essa fórmula:

 

=SOMA(B2:B10)/(CONT.VALORES(B2:B10)-CONT.SE(B2:B10;"faltou"))

 

Abraço.

 

 



#6 Vereda    

Vereda
  • Participante
  • 4 mensagens

Publicado 20 January 2014 - 04:29 PM

Olá.

Já experimentei todas as sugestões, mas não resulta.

Será que me podiam devolver o ficheiro 'Cálculo da Média.zip' corrigido?

Obrigado.



#7 dignusI    

dignusI
  • Participante
  • 48 mensagens

Publicado 20 January 2014 - 04:43 PM

Segue anexo com a fórmula sugerida.
Abraço.

Arquivos Anexados



#8 Vereda    

Vereda
  • Participante
  • 4 mensagens

Publicado 20 January 2014 - 05:15 PM

Olá.

Já entendi porque a sugestão do DIGNUSI não funcionava. O idioma do meu Excel só aceita desta forma:

=SOMA(B2:B10)/(CONTAR.VAL(B2:B10)-CONTAR.SE(B2:B10;"faltou"))

 

Obrigado a todos pela preciosa ajuda. Esta coisa dos fóruns é uma maravilha. Agora já sei a quem recorrer quando surgir mais algum problema.

Aquele abraço!



#9 markmzz    

markmzz
  • Participante
  • 395 mensagens

Publicado 20 January 2014 - 06:42 PM

Olá VEREDA,

 

Outra fórmula:

 

=SOMA(B2:B10)/CONTAR.SE(B2:B10;"<>faltou")

 

Markmzz