#

Jump to content

  • Login via Facebook Login com Twitter
  • Cadastre-se no Fórum do BABOO!





 

Foto

EXCEL - Atribuir valor numérico a uma palavra

excel dúvida atributos

Melhor Resposta dignusI, 20/jan/14 04:19 h

Olá Vereda, a fórmula sugerida pelo MARKMZZ acredito que dá certo.

 

Pelo que entendi de sua planilha, quando o aluno "faltou" é necessário não entrar na média.

Dessa forma, utilize essa fórmula:

 

=SOMA(B2:B10)/(CONT.VALORES(B2:B10)-CONT.SE(B2:B10;"faltou"))

 

Abraço.

 

 

LER A RESPOSTA COMPLETA


Minimizar/MaximizarImagens para Papel de Parede

  • 3D - 07
  • Paisagens e animais - 02
  • Paisagem - 55
  • Cavalos - 07
  • Bing - Foto 40
  • Chocolate - 03
  • Olhos - 19
  • Cavalos - 32
  • Flores - 71
  • Carros - 20

  • Faça login para responder
Existem 8 respostas neste tópico

#1
Link desta mensagem
Vereda

Vereda
  • Participante
  • 4 mensagens

Publicado 20/jan/14 03:33 h

Olá a todos.

Tenho uma tabela com resultados de provas escolares, onde surge a palavra «desistiu» no lugar de alguns resultados. No entanto, quando faço a média aritmética, apenas são considerados os resultados numéricos. O que eu queria era atribuir 0,0 à palavra «desistiu», fazendo com que a média considerasse também o número de vezes [ou de zeros] que a palavra surge nos resultados.

Será que alguém me sabe ajudar?

Aguardo com enorme expectativa pelas vossas sugestões.

Obrigado.



Publicidade
Publicidade

#2
Link desta mensagem
dignusI

dignusI
  • Participante
  • 55 mensagens

Publicado 20/jan/14 03:40 h

Olá Vereda, boa tarde!

 

Pensei em duas sugestões:

 

1) Pensando que o intervalo em que estão as notas é de B2 até B10 sugiro o seguinte:

 

Ao invés de simplesmente fazer a fórmula =MÉDIA(B2:B10) faça a média da seguinte fórmula:

 

=SOMA(B2:B10)/CONT.VALORES(B2:B10)

 

Dessa maneira, somamos todas as notas numéricas, e dividimos pelo número de células numéricas ou com o texto desistiu.

 

ou

 

2) Utilizar o CTRL + L, clicar em substituir

 

Localizar os textos «desistiu» e substituir por 0,00.

 

Se não ajudar, se for  possível posta a planilha para nós, no formato "ZIP" (clica com botão direito no arquivo, Enviar para "Pasta Compactada").

 

Aguardamos teu retorno.

 

Abraço.



#3
Link desta mensagem
markmzz

markmzz
  • Participante
  • 395 mensagens

Publicado 20/jan/14 04:00 h

Olá VEREDA,

 

Faça alguns testes com a seguinte fórmula:

 

=MÉDIAA(B2:B20)

 

e verifique se resolve o seu problema.

 

Markmzz


Editado por markmzz 20/jan/14 04:01 h
''


#4
Link desta mensagem
Vereda

Vereda
  • Participante
  • 4 mensagens

Publicado 20/jan/14 04:11 h

Olá a todos.

Já tentei com as sugestões que me deram, mas não resultou como eu pretendo.

Segue em anexo um exemplo do problema.

Obrigado pela vossa generosidade.

Arquivos Anexados



#5
Link desta mensagem
dignusI

dignusI
  • Participante
  • 55 mensagens

Publicado 20/jan/14 04:19 h   Melhor Resposta

Olá Vereda, a fórmula sugerida pelo MARKMZZ acredito que dá certo.

 

Pelo que entendi de sua planilha, quando o aluno "faltou" é necessário não entrar na média.

Dessa forma, utilize essa fórmula:

 

=SOMA(B2:B10)/(CONT.VALORES(B2:B10)-CONT.SE(B2:B10;"faltou"))

 

Abraço.

 

 



#6
Link desta mensagem
Vereda

Vereda
  • Participante
  • 4 mensagens

Publicado 20/jan/14 04:29 h

Olá.

Já experimentei todas as sugestões, mas não resulta.

Será que me podiam devolver o ficheiro 'Cálculo da Média.zip' corrigido?

Obrigado.



#7
Link desta mensagem
dignusI

dignusI
  • Participante
  • 55 mensagens

Publicado 20/jan/14 04:43 h

Segue anexo com a fórmula sugerida.
Abraço.

Arquivos Anexados



#8
Link desta mensagem
Vereda

Vereda
  • Participante
  • 4 mensagens

Publicado 20/jan/14 05:15 h

Olá.

Já entendi porque a sugestão do DIGNUSI não funcionava. O idioma do meu Excel só aceita desta forma:

=SOMA(B2:B10)/(CONTAR.VAL(B2:B10)-CONTAR.SE(B2:B10;"faltou"))

 

Obrigado a todos pela preciosa ajuda. Esta coisa dos fóruns é uma maravilha. Agora já sei a quem recorrer quando surgir mais algum problema.

Aquele abraço!



#9
Link desta mensagem
markmzz

markmzz
  • Participante
  • 395 mensagens

Publicado 20/jan/14 06:42 h

Olá VEREDA,

 

Outra fórmula:

 

=SOMA(B2:B10)/CONTAR.SE(B2:B10;"<>faltou")

 

Markmzz




  Publicidade  
Publicidade



Tópicos com palavra-chave: excel, dúvida, atributos