Jump to content

Foto

EXCEL - Fórmula com células vazia

excel


Existem 3 respostas neste tópico

#1 mariaeduardac    

mariaeduardac
  • Participante
  • 2 mensagens

Publicado 04 February 2014 - 03:29 PM

Olá,

 

Tenho uma planilha de Controle de Pagamento de NF's para controlar os vencimentos, quando está faltando uma semana ela fica como "à vencer" quando passa da data fica como "atrasado", e assim por diante.

Mas quando eu não preencho à coluna "data de vencimento" a coluna "Situação" fica "#N/D" e a coluna "Dias que faltam para o vencimento" fica "-41674" como se a célula vazia equivalesse a data 00/01/01, assim:

 

Data de vencimento         Situação             Dias que faltam para o vencimento      Data de pagamento

                                          #N/D                                 -41674

 

 

Que fórmula aplico para que enquanto a data não é preenchida as outras colunas não sejam preenchidas??

 

 

Arquivos Anexados


Editado por mariaeduardac 04 February 2014 - 03:32 PM
''


#2 Mourense    

Mourense

    Office Expert

  • Colaborador
  • 1296 mensagens

Publicado 04 February 2014 - 08:37 PM

Boa noite Maria Eduarda

 

 

Baixe a planilha e veja se é isto que vc deseja:

 

Attached File  04_02_14_TESTE controle notas fiscais_Patropi.zip   33.29KB   38 downloads

 

Dê retorno.

 

Um abraço.

 

 


Se a resposta foi útil, clique em Curtir

Se a resposta atendeu, clique no botão melhor resposta.
 


#3 markmzz    

markmzz
  • Participante
  • 395 mensagens

Publicado 04 February 2014 - 08:38 PM

Olá MariaEduardaC,

 

Faça testes com as seguintes fórmulas:

 

Em H5

 

=SE(ÉNÚM(I5);PROC(I5;{-9999;1;8};{"Atrasado ";"À vencer";"Não pago"});I5)

 

Em I5

 

=SE(J5;"Pago";SE(E5;E5-HOJE();""))

 

Markmzz



#4 Wilian Santos    

Wilian Santos
  • Participante
  • 3 mensagens

Publicado 12 February 2014 - 09:58 AM

Suas formulas estão corretas só estão incompletas faça o seguinte muito simples fácil e rápido

suponte que os dados estEgem assim:

         

               A                               B                                              C                                               D

1 Data de vencimento         Situação             Dias que faltam para o vencimento      Data de pagamento

2

3

4

 

Na Célula B2 onde se encontra a formula da situação, abra ela e no inicio depois do = coloque:

 

se(A2="";"";

 

nos dias que faltam para vencer a mesca coisa, abra a sua formula depois do = coloque:

 

se(B2="";"";

 

colocando dessa forma estará informando que ando a célula de data não tiver NADA irá aparecer NADA ao contrário fara o calculo que você deseja

 

vai ficar assim na coluna de situação

 

=SE(E5="";"";SE(I5="Pago";"Pago";PROCV(I5;Fórmula!$A$2:$C$4;3)))

 

e assim na coluna de vencimento

 

=SE(E5="";"";SE(J5<>"";"Pago";E5-HOJE()))


Editado por Wilian Santos 12 February 2014 - 10:09 AM
''









Tópicos com palavra-chave: excel