Ir para conteúdo

osvaldomp

Colaborador
  • Postagens

    1.337
  • Desde

  • Última visita

Social Info

Sobre osvaldomp

  • Título
    Office Expert

Perfil

  • Escolaridade
    Superior completo
  • Área Profissional
    Engenharia
  • Nível Profissional
    Profissional curso superior
  • Estado
    São Paulo
  • Sexo
    masculino

Últimos Visitantes

9.944 visualizações
  1. Microsoft Office

    Se a única operação realizada foi a desinstalação do Office e esta ocorreu sem problemas então os arquivos não foram afetados. Reinstale o Office e os arquivos abrirão sem problemas.
  2. A fórmula que o Décio sugeriu é fórmula matricial, como ele já havia comentado, e por isso deve ser finalizada com Ctrl+Shift+Enter e não somente Enter. Então, no seu exemplo, selecione a célula que contém a fórmula (F7), aperte F2 e em seguida aperte juntas Ctrl+Shift+Enter. A fórmula retornará 42,99.
  3. Soma em várias Planilhas

    Decio, beleza? A função SOMARPRODUTO já é uma função matricial nativa, por isso ela dispensa a entrada com Ctrl+Shift+Enter.
  4. Soma em várias Planilhas

    Outra opção é manter a estrutura igual em todas as planilhas, por exemplo igual à planilha Janeiro, inclusive a ordem dos nomes, e usar esta fórmula em E2 da planilha Total ~~~> =SOMA(Janeiro:Março!G3) e arrastar para baixo.
  5. Comando SE para uma célula variável

    Olá, Apolo. Veja se a fórmula abaixo em A6 atende. =SE(E(A1>="10:00"+0;A1<="14:00"+0);"Palestra no Auditório: das 10h às 14h - Pausa das 12h às 13h";"")
  6. Separar um número em grupos

    No arquivo anexo uma solução alternativa via macro. separando numeros.xlsm
  7. Olá, Geneci. No seu exemplo a relação de datas em E1:E9 está conforme abaixo. 02/01/2017 05/06/2017 17/07/2017 21/09/2017 25/09/2017 28/09/2017 18/10/2017 26/06/2017 04/03/2017 Veja se entendi corretamente o que você quer. questão 1 - data mais antiga ~~~> =MÍN(E1:E9) ~~~> retorna 02/01/2017 questão 2 - data mais próxima de hoje (considerei que você quer a data futura mais próxima de hoje) ~~~> =MÍN(SE(E1:E9>HOJE();E1:E9)) esta é fórmula matricial ~~~> retorna 21/09/2017 ~~~> mas no seu resultado esperado você colocou 28/09/2017 (?) questão 3 - data mais distante (considerei que você quer a data futura mais distante de hoje) ~~~> =MÁXIMO(SE(E1:E9>HOJE();E1:E9)) esta é fórmula matricial~~~> retorna 18/10/2017 obs. 1.se as duas primeiras fórmulas retornarem #NOME? substitua MÍN por MÍNIMO. 2. HOJE() = 19/09/2017
  8. Salvar aba específica em PDF - Excel VBA

    Exato, a causa do erro é a planilha estar oculta. Experimente o código abaixo como alternativa. Sub cotacao1_PDF_V2() Dim nome_arquivo As String Application.ScreenUpdating = False If MsgBox("Deseja gerar um PDF da cotação?", vbYesNo + vbQuestion, "Cotação indicativa D&O") = vbNo Then Exit Sub nome_arquivo = Sheets("Cot1").Range("A63").Value With Sheets("Cot1") .Visible = 1 .ExportAsFixedFormat Type:=xlTypePDF, Filename:=Format(Date, "yyyyddmm") & "_1.3.4_" & nome_arquivo .Visible = 0 End With MsgBox "Salvo com Sucesso!", vbInformation, "Cotação indicativa D&O" Application.ScreenUpdating = True End Sub
  9. Macro para apagar somente linhas filtradas

    Experimente: Sub DeletaLinhasFiltradas() Dim LR As Long Application.ScreenUpdating = False With ActiveSheet LR = .Cells(Rows.Count, 1).End(3).Row .AutoFilterMode = False .Range("A1:M" & LR).AutoFilter Field:=2, Criteria1:="<>*x*" _ , Operator:=xlAnd, Criteria2:="<>*y*" If .AutoFilter.Range.Columns(1).SpecialCells(xlCellTypeVisible).Count > 1 Then .Range("A2:M" & LR).SpecialCells(xlCellTypeVisible).EntireRow.Delete End If .AutoFilterMode = False .Range("A1:M" & LR).AutoFilter Field:=2, Criteria1:="=xxx*" _ , Operator:=xlOr, Criteria2:="=yyy*" If .AutoFilter.Range.Columns(1).SpecialCells(xlCellTypeVisible).Count > 1 Then .Range("A2:M" & LR).SpecialCells(xlCellTypeVisible).EntireRow.Delete End If .AutoFilterMode = False End With Application.ScreenUpdating = True End Sub
  10. Salvar aba específica em PDF - Excel VBA

    Não vejo erro de sintaxe nesta linha ThisWorkbook.Sheets("Cot1").Select Qual o texto que aparece na Caixa de Erro? Não seria "subscrito fora do intervalo" ? Se sim, o erro ocorre porque no arquivo não existe planilha com o nome que foi referenciado no código.
  11. Erro 9 Tempo de Execução

    O erro gerado não é de sintaxe e sim de "subscrito fora do intervalo", e ocorre porque não existe no arquivo o nome de planilha referenciado no código.
  12. Erro 9 Tempo de Execução

    Não consigo ver algum erro de sintaxe nesse código.
  13. Folha de ponto automática

    Olá, Geneci. Segue uma opção via macro. Sub PreparaFolhaFreq() Dim d1 As Date, d2 As Date, d3 As Long d1 = DateSerial(Year(Sheets("MES").[A1]), Month(Sheets("MES").[A1]) - 1, 16) d2 = DateSerial(Year(Sheets("MES").[A1]), Month(Sheets("MES").[A1]), 15) d3 = d2 - d1 With Sheets("FOLFREQ") .[C10] = d1 & " a " & d2 .Rows("17:" & .Cells(Rows.Count, 1).End(3).Row - 4).Delete .Rows("16:" & d3 + 15).Insert .[A16] = d1: .[A16].NumberFormat = "dd" .[A16].AutoFill .[A16].Resize(d3 + 1) End With End Sub
  14. Tabela com várias valores

    A sua descrição não é precisa e nem completa. Aqui vai um chute: se você quer arrastar a fórmula pela coluna remova o endereço absoluto =ÍNDICE('TABELA IMPOSTOS'!$I$1:$L$85;CORRESP(CONCATENAR($D$1;$B$6);'TABELA IMPOSTOS'!C:C;0);CORRESP($D$2;'TABELA IMPOSTOS'!$I$1:$L$1;0)) =ÍNDICE('TABELA IMPOSTOS'!$I$1:$L$85;CORRESP(CONCATENAR($D$1;B6);'TABELA IMPOSTOS'!C:C;0);CORRESP($D$2;'TABELA IMPOSTOS'!$I$1:$L$1;0)) Se não for isso tente descrever exatamente o que você quer, forneça mais exemplos e coloque o resultado esperado para cada exemplo.
×