Conteúdo: Default Ardósia Uva Barbie Morango Pôr do sol Banana Folha Chocolate Madeira
Fundo: Default Ardósia Uva Barbie Morango Pôr do sol Banana Folha Chocolate Madeira
Desenho: Liso Onda Linha Retalho Madeira Rocha Couro Colméia Vertical Triângulo
Bem-vindo ao Fórum do BABOO!

Desde 2000 o Fórum do BABOO tem ajudado milhões de internautas de Windows a resolverem seus problemas e dúvidas, além de ajudar na remoção de vírus e malwares de seus computadores. Somos o único fórum brasileiro coordenado por um especialista com reconhecimento internacional pela sua competência em Windows, então se você tem uma dúvida ou problema que nenhum outro fórum resolve, poste-a aqui pois o MVP Babooadora desafios!
  

O Fórum do BABOO também conta com a participação exclusiva do administrador da área de Segurança MVP Mr.Million que tem reconhecimento internacional da Microsoft pelo seu incansável trabalho ajudando os internautas a remover vírus e malwares dos seus computadores. Se o seu computador está infectado por algum vírus, ele te ajudará a removê-lo!
  

Nosso time de especialistas também inclui Patropi  Osvaldomp  Caze  Ciro-Mota  XERLOUCO ROUMS  Tatha que responderão suas dúvidas sobre diversos assuntos.
 

Participe da nossa comunidade! 

 

osvaldomp

Colaborador
  • Postagens

    1.183
  • Desde

  • Última visita

6 Seguidores

Sobre osvaldomp

  • Rank
    Office Expert

Perfil

  • Escolaridade
    Superior completo
  • Área Profissional
    Engenharia
  • Nível Profissional
    Profissional curso superior
  • Estado
    São Paulo
  • Sexo
    masculino

Últimos Visitantes

7.957 visualizações
  1. Acrescente a segunda linha abaixo. Private Sub Worksheet_Change(ByVal Target As Range) If Target.Count > 1 Then Exit Sub
  2. Paulo, veja se é isso. =SE(E(OU(A1=7,97;A1=19,91);OU(B1=220;B1="220/440"));"MONO";SE(E(OU(A1=13,8;A1=34,5);OU(B1=220;B1="220/440"));"BI";SE(E(OU(A1=13,8;A1=34,5);B1="220/380");"TRI")))
  3. Veja se ajuda: 1. soma dos alqueires ---> =SOMA(INT(D3:H3)) matricial 2. soma dos litros ---> =SOMA(D3:H3-INT(D3:H3))*100 matricial 3. conversão da soma de litros para alqueires ---> =SOMA(D3:H3-INT(D3:H3))*100/60 matricial fórmula final, juntando as fórmulas 1 e 3 acima ---> total em alqueires ---> =SOMA(INT(D3:H3))+SOMA(D3:H3-INT(D3:H3))*100/60 matricial total a pagar --> =L6*$L$2 obs. para inserir uma fórmula matricial, após colar a fórmula na célula aperte F2 e em seguida aperte juntas Ctrl+Shift+Enter
  4. Talvez seja possível via macro. Se essa for uma solução aceitável disponibilize uma amostra do seu arquivo e indique na própria planilha qual o intervalo a ser controlado e qual a formatação aplicada nas células controladas.
  5. Testaí: =DATA(ANO(J5)+L8;MÊS(J5)+K8;DIA(J5)+J8)
  6. sugestão - disponibilize uma amostra do seu arquivo com alguns dados, com o resultado desejado e com as necessárias explicações nas próprias planilha. Veja as instruções abaixo da janela de respostas de como anexar arquivos aqui no fórum.
  7. A função CONT.SE não é 3D, ou seja, ela não suporta referência a múltiplas planilhas. Experimente: =ÍNDICE(FREQUÊNCIA(101:120!I3;130);2)
  8. No seu código falta atribuir valor ao elemento da matriz employee(n) = n Sub TestaMatriz() Dim employee(1 To 5), n As Long For n = 1 To 5 employee(n) = n Next n For n = 1 To 5 MsgBox employee(n) Next n End Sub Sub TestaMatrizV2() Dim employee(), n As Long ReDim employee(1 To 5) For n = 1 To 5 employee(n) = n Next n For n = 1 To 5 MsgBox employee(n) Next n End Sub
  9. Olá, Cludir. Substitua esta linha FormGIDUR.Show por esta FormGIDUR.Show vbModeless
  10. Se você quer enviar por e-mail uma versão em .PDF da planilha "Impressão": 1. exclua esta linha do código que passei ---> .PrintOut copies:=1 2. acrescente as duas linhas abaixo em vermelho ao código que passei: a primeira ativa a planilha "Imprimir" e a segunda chama o seu código Next v Sheets("Impressão").Activate salvar_enviar_PDF End Sub
  11. Olá, amigo. Experimente o código abaixo no lugar do anterior. Private Sub Worksheet_Change(ByVal Target As Range) If Target.Column = 4 Then Target.Offset(0, 4).Value = Target.Offset(0, 4).Value + Target.Value ElseIf Target.Column = 3 Then Target.Offset(0, 4).Value = Date End If End Sub
  12. Olá, Kayo. Veja se o código abaixo atende. Se não atender, sugiro que você explique com exatidão o que você deseja que o código faça e em que condições. Private Sub Worksheet_Change(ByVal Target As Range) If Target.Column = 4 Then Target.Offset(0, 4).Value = Target.Offset(0, 4).Value + Target.Value ElseIf Not Intersect(Target, Range("A2:A1000")) Is Nothing Then Target.Offset(0, 4).Value = Date End If End Sub
  13. Olá, Geneci. Veja se entendi corretamente. Substitua o código existente conforme abaixo. opção 1 - insere na célula somente o dia da data escolhida Sub Calendario() ActiveCell.Value = Format(GetCalendário, "d") End Sub opção 2 - insere na célula a data escolhida e formata a célula para exibir somente o dia da data escolhida Sub Calendario() ActiveCell.Value = GetCalendário ActiveCell.NumberFormat = "d" End Sub
O site BABOO está no ar para informar e ajudar o internauta de Windows. Este site foi publicado em 1999 por Aurélio "Baboo", engenheiro e um dos maiores especialistas brasileiros em Windows, que trabalha profissionalmente com esse sistema operacional desde 1987. Desde 2004 ele é premiado anualmente pela Microsoft como MVP (Most Valuable Professional) pela sua contribuição e ajuda à comunidade de usuários de Windows.

Em 2001 foi criado o
Fórum do BABOO para ajudar o internauta brasileiro a solucionar problemas e dúvidas sobre Windows, Segurança, Office, Hardware e outros temas. Desde 2010 a Microsoft também tem premiado o Mr.Million, administrador da área de Segurança do Fórum do BABOO, pelo seu incansável trabalho ajudando os internautas a remover vírus e malwares dos seus computadores. Atualmente ele é o único MVP brasileiro de Segurança em desktop.

O BABOO é o único site brasileiro coordenado por um especialista com reconhecimento internacional pela sua competência em Windows e que participa diariamente e ativamente nos comentários e discussões do site e fórum BABOO.