Este fórum foi descontinuado. LEIA AQUI e participe da Comunidade BABOO :)

A área de Remoção de Malwares está aberta na Comunidade BABOO. LEIA AQUI

Ir para conteúdo

osvaldomp

Time BABOO
  • Postagens

    1.581
  • Desde

  • Última visita

  • Days Won

    63

Histórico de Reputação

  1. Gostei
    osvaldomp recebeu reputação de Patropi em Macro copiar e colar com condição   
    Experimente:
    Sub ReplicaRegistros() Dim c As Range, r As Long With Sheets("pesquisa") For r = 2 To .Cells(Rows.Count, 1).End(3).Row Set c = Sheets("Planilha5").[A:A].Find(.Cells(r, 1), lookat:=xlWhole) If Not c Is Nothing Then Sheets("Planilha5").Cells(c.Row, 2).Resize(, 24).Value = .Cells(r, 2).Resize(, 24).Value End If Next r End With On Error Resume Next Set c = Sheets("Planilha5").[A:A].Find(Sheets("pesquisa").Cells(r, 1), lookat:=xlPart) End Sub  
  2. Gostei
    osvaldomp opinou Henrique Cruz em Formula SE(E Retornando "FALSO"   
    Osvaldo, consegui muito obrigado pela ajuda!!
    Att
  3. Obrigado!
    osvaldomp recebeu reputação de GENECI em Mostrar o conteúdo da célula após o hífen   
    Olá, Geneci.
    Veja se a fórmula abaixo atende.
    =ARRUMAR(DIREITA(A1;NÚM.CARACT(A1)-PROCURAR("-";A1)))  
  4. Gostei
    osvaldomp opinou Duaaardo em Ajuda com Lista Suspensa   
    Testei aqui, ficou perfeito!
    Mais uma vez, muito obrigado!
  5. Obrigado!
    osvaldomp recebeu reputação de Duaaardo em Ajuda com Lista Suspensa   
    Veja se atende:
    Instale uma cópia do código abaixo no módulo da planilha Plan1, assim:
    1. copie o código daqui
    2. clique com o direito na guia daquela planilha e escolha 'Exibir Código'
    3. cole o código na janela em branco que vai se abrir
    4. feito! 'Alt+Q' para retornar para a planilha e testar
    Private Sub Worksheet_Change(ByVal Target As Range) Dim p As String If Intersect(Target, [H22:H76]) Is Nothing Or Target.Value <> _ "CONCLUÍDO(SENDO TRATADO ATRAVÉS DO PROTOCOLO XXXXXXX)" Then Exit Sub p = InputBox("INSIRA ABAIXO O NÚMERO DO PROTOCOLO" & vbLf & "EM SEGUIDA CLIQUE EM OK OU APERTE Enter") If p = "" Then Target.Value = "": Exit Sub Target.Value = "CONCLUÍDO(SENDO TRATADO ATRAVÉS DO PROTOCOLO " & p & ")" End Sub  
    funcionamento - ao selecionar uma célula no intervalo H22:H76 e escolher na lista de Validação a opção CONCLUÍDO(SENDO TRATADO ATRAVÉS DO PROTOCOLO XXXXXXX) (adotei esta opção pois não encontrei a opção Concluído(Sendo tratado pelo atendimento XXXXXXX) que você citou no primeiro post; altere no código se precisar), o código irá solicitar a inserção do número do protocolo em uma Caixa de Entrada, em seguida o código irá colocar na célula a opção escolhida, sendo XXXXXXX substituído pelo número do protocolo inserido na Caixa.
    obs. a Validação na sua planilha de exemplo aceita conteúdos fora da lista, então sugiro que seja refeita antes de testar o código.
     
  6. Obrigado!
    osvaldomp recebeu reputação de GENECI em Somar especificando parcialmente uma célula alfa.   
    Olá, Geneci.
    Experimente a fórmula abaixo.
    =SOMASE(DADOS!C3:C1000;"*"&F1;DADOS!D3:D1000)  
  7. Obrigado!
    osvaldomp recebeu reputação de GENECI em Alterar a fórmula   
    Olá, Geneci.
    Veja se a fórmula abaixo atende.
    =SE(E(DIA.DA.SEMANA(FIMMÊS(HOJE();0))=1;HOJE()>=FIMMÊS(HOJE();0)-2);"FATURA FECHADA";"FATURA ABERTA")  
  8. Gostei
    osvaldomp opinou GENECI em Criar ou Renomear do arquivo com o mes e ano atual.   
    Boa tarde! Sr. Osvaldo. 
    impressionante, inacreditável, funcionou.
    Muito obrigado. 
  9. Gostei
    osvaldomp recebeu reputação de Patropi em Criar ou Renomear do arquivo com o mes e ano atual.   
    Olá, Geneci.
    Veja se atende.
    1. cole uma cópia do código abaixo em um módulo comum do seu arquivo
    2. salve o arquivo como Habilitado para Macro
    3. rode o código abaixo
    4. daí em diante bastará rodar o código para obter o resultado que você deseja
    Sub ArqSalvaAtualDeletaAnterior() Dim ant As String, nom As String ant = ThisWorkbook.FullName nom = Left(ThisWorkbook.Name, 16) & "-" & Format(Date, "mmmm-yyyy") Application.DisplayAlerts = False ThisWorkbook.SaveAs Filename:=ThisWorkbook.Path & "\" & nom Application.DisplayAlerts = True On Error Resume Next Kill ant End Sub  
  10. Gostei
    osvaldomp recebeu reputação de Patropi em Criar ou Renomear do arquivo com o mes e ano atual.   
    Olá, Geneci.
    Veja se atende.
    1. cole uma cópia do código abaixo em um módulo comum do seu arquivo
    2. salve o arquivo como Habilitado para Macro
    3. rode o código abaixo
    4. daí em diante bastará rodar o código para obter o resultado que você deseja
    Sub ArqSalvaAtualDeletaAnterior() Dim ant As String, nom As String ant = ThisWorkbook.FullName nom = Left(ThisWorkbook.Name, 16) & "-" & Format(Date, "mmmm-yyyy") Application.DisplayAlerts = False ThisWorkbook.SaveAs Filename:=ThisWorkbook.Path & "\" & nom Application.DisplayAlerts = True On Error Resume Next Kill ant End Sub  
  11. Obrigado!
    osvaldomp recebeu reputação de GENECI em Comando-se-com-um-grupo-de-celulas-alfa   
    Olá, Geneci.
    Experimente:
    =SE(CONT.SE(B2:B9;"ERODOTO");50;5)  
  12. Gostei
    osvaldomp opinou guitar hero em Formula SE com Célula Vazia   
    Osvaldo!
    Muito obrigado pela solução, ficou perfeito!
    Grande abraço!
    Att,
    Israel
  13. Obrigado!
    osvaldomp recebeu reputação de guitar hero em Formula SE com Célula Vazia   
    =SE(A1="";"";SE(A1=B1;"ok";"erro"))
    ou
    =SE(OU(A1="";B1="");"";SE(A1=B1;"ok";"erro"))
  14. Obrigado!
    osvaldomp recebeu reputação de GENECI em Data autocomplemento   
    Olá, Geneci.
    Veja se atende. Cole cópia do código abaixo no módulo da planilha.
    Dim w As Boolean
    Private Sub Worksheet_Change(ByVal Target As Range)
     If Target.Column > 1 Then Exit Sub
     If w Then: w = False: Exit Sub
     Target.NumberFormat = "General"
     w = True: Target.Value = Target.Value
     If Target.Value > 40000 Then
      Target.NumberFormat = "dd/mm/yyyy"
     ElseIf Target.Value > 0 And Target.Value <= Day(DateSerial(Year(Date), Month(Date) + 1, 0)) Then
      w = True: Target.Value = DateSerial(Year(Date), Month(Date), Target.Value)
     End If
    End Sub
     
  15. Obrigado!
    osvaldomp recebeu reputação de GENECI em Comando, SE usar letras e somar   
    Olá, Geneci.
    Veja se a fórmula abaixo  atende.
    =SOMASE(C6:C16;C1;G6:G16)
  16. Gostei
    osvaldomp opinou Igor Lopes em Problemas ao comparar Notas Escolares.   
    Obrigado Osvaldo funcionou! 😄😄😄
  17. Obrigado!
    osvaldomp recebeu reputação de Igor Lopes em Problemas ao comparar Notas Escolares.   
    Considerando:
    Média em J10
    Recuperação em L10
    Frequência em O10
    Experimente a fórmula abaixo.
    =SE(O10<75%;"reprovado";SE(OU(J10>=4,5;L10>=4,5);"aprovado";SE(L10="";"recuperação";"reprovado")))
  18. Obrigado!
    osvaldomp recebeu reputação de ILAURATTO em Macro transpor linhas em colunas com identificador ao lado   
    Me parece que você editou o seu post e acrescentou que quer o resultado nas colunas A e B, então substitua conforme abaixo.
    Sheets("Plan2").Cells(c + 1, 1).Resize(k - 1).Value = n.Value
    Sheets("Plan2").Cells(c + 1, 2).Resize(k - 1).Value = _
  19. Gostei
    osvaldomp recebeu reputação de Patropi em unir colunas no excel   
    Experimente a fórmula abaixo em uma coluna vazia.
    =DESLOC(B$9;INT((LIN(A1)-1)/12);MOD(LIN(A12);12))
  20. Ajudou
    osvaldomp recebeu reputação de GabrielLV em Criando uma Tabela de Diárias para HOTELARIA   
    A ordem das operações não importa:
    =(120*0,03)/100 = 0,036
    =120*(0,03/100) = 0,036
    =120*0,03/100 = 0,036
    =0,03/100*120 = 0,036
    =120/100*0,03 = 0,036
     
    diária bruta = 160,65

    diária líquida ~~~> diária bruta x 0,95 ~~~> 160,65 * 0,95 = 152,61

    diária bruta ~~~> diária líquida / 0,95 ~~~> 152,61 / 0,95 = 160,65  
     
  21. Gostei
    osvaldomp recebeu reputação de kayankarreira em Como retirar marca dágua nas paginas   
    Olá, Jore.
    Me parece que não existe essa possibilidade de ativar/desativar a exibição do texto que indica o número da página.
    Não sei se isto serviria para o seu objetivo: após ativar a Visualização da Quebra de Página basta clicar em Normal para remover aquele texto, permanecendo somente as linhas pontilhadas que indicam as quebras de páginas.
    Cabe comentar também que os textos que indicam os números das páginas no modo Visualização da Quebra de Página não serão impressos, como são impressas as marcas d'água inseridas como Plano de Fundo.
  22. Gostei
    osvaldomp recebeu reputação de kayankarreira em Como retirar marca dágua nas paginas   
    Olá, Jore.
    Me parece que não existe essa possibilidade de ativar/desativar a exibição do texto que indica o número da página.
    Não sei se isto serviria para o seu objetivo: após ativar a Visualização da Quebra de Página basta clicar em Normal para remover aquele texto, permanecendo somente as linhas pontilhadas que indicam as quebras de páginas.
    Cabe comentar também que os textos que indicam os números das páginas no modo Visualização da Quebra de Página não serão impressos, como são impressas as marcas d'água inseridas como Plano de Fundo.
  23. Gostei
    osvaldomp recebeu reputação de Jore em numero aleatorio sem repetir somente em A1   
    Seguem duas alternativas.
     
     
    Gera Números Aleatórios V2.xlsm
    Gera Números Aleatórios V3 Falado.xlsm
  24. Gostei
    osvaldomp opinou Jore em informando a data e a hora que o arquivo foi aberto.   
    Osvaldo o mestre do Excel!
    Obrigado por suas contribuições!!
  25. Gostei
    osvaldomp recebeu reputação de Jore em EXCEL - Macro para copiar dados e preencher data e forma de pagamento   
    Veja se o link abaixo ajuda.
    Outras formas são o sábio Google e os fóruns, além de cursos.
    Para saber sobre determinado comando, no editor de VBA clique sobre o comando e aperte F1 para acessar a ajuda.
    http://www.bertolo.pro.br/FinEst/SemanaContabeis2007/MacroExcel.pdf
×
×
  • Criar Novo...