Ir para conteúdo

BABOO e KTS 2018 no YouTube Loja online do BABOO

doraimom

Participante
  • Postagens

    7
  • Desde

  • Última visita

Sobre doraimom

  • Data de Nascimento 01/01/1900

Perfil

  • Escolaridade
    Superior completo
  • Área Profissional
    Engenharia
  • Nível Profissional
    Autônomo
  • Estado
    São Paulo
  • Sexo
    masculino

Como me contatar

  • URL do site ou blog
    nenhum
  • LinkedIn
    nao tenho
  • Facebook
    www.facebook.com/a
  • Twitter
    nao tenho
  • Google+
    nao tenho
  1. SGI, sistema de gestão imobiliária. O programa em si consiste em uma pasta apenas com os arquivos de fotos, banco de dados, configuração e o executável autorun. Não vai achar no mercado o programa, mas posso até te fornecer uma cópia da pasta se tiver interesse.
  2. Me parece que eu fui bloqueado de postar qualquer coisa no forum depois de enviar 3 postagens seguidas no mesmo tópico. Agora que você enviou uma mensagem eu consegui acesso novamente. Primeiramente quero pedir desculpas porque fiz algumas confusões aqui. Eu criei em vários forums duas frentes de trabalho. Uma frente tentava descobrir como impedir que o Windows creators bloqueasse a instalação de programas antigos. Este era o intuito deste tópico aqui. A segunda frente de trabalho, pro caso de não conseguir forçar a instalação de programas antigos no Windows 10 creators, era de como fazer o nosso programa imobiliário funcionar com as versões mais novas do Firebird. Neste tópico aqui no forum eu misturei as duas coisas. Tudo bem. Vamos tentar organizar então: Frente de Trabalho 1 - Impedir com que o Windows Creators bloqueie a instalação de programas: SOLUCIONADO: https://windowsten.info/forum/compat...lity-assistant Frente de Trabalho 2 - Fazer o programa da imobiliária funcionar com a versão 2.5 ou 3.0 do Firebird mais atuais. Sem solução. Aqui eu acabei fazendo o tópico do Windows virar um tópico do Firebird. Espero a compreensão dos moderadores. Até onde eu sei existe sim login e senha para acessar o banco de dados como padrão no FireBird. Os dois arquivos .INI do nosso programa imobiliário, inclusive, contêm os parâmetros já citado user=SYSDB e password=masterkey. Portanto, pelo quase nada que sei sobre o SGI até hoje, essa é a conta padrão do firebird, com a senha padrão e, portanto, como tudo sempre esteve dentro do padrão nos bastava instalar o Firebird que tudo já funcionava, já que o Firebird parece já aceitar essas configurações desde sua instalação crua, sem necessidade de editar nada, nenhum arquivo e nenhuma configuração do firebird. Tudo que sempre fizemos foi instalar o Firebird e abrir o arquivo autorun .EXE da imobiliária na pasta do programa. Pra nós o programa é visto como uma pasta com um executável dentro dela, só isso, e o Firebird é visto apenas como a ferramenta usada por todos os computadores para acessar a pasta de de referência em uma máquina específica que contém o banco de dados centralizado que é acessado e compartilhado com todos na rede local.
  3. Eu entrei pelo prompt de comando na pasta BIN do firebird e useu o comando: Ele não entra. Porém, quando eu coloco a senha como masterkey ele entra. Ou seja, o firebird está vindo de instalação com a senha masterkey definida. Eu fiz a alteração que você sugeriu colocando password=masterkey ao invés de 12345, porém, o erro ainda se mantém. Existe um arquivo que nunca precisei editar, mas segue o conteúdo dele. Talvez ajuda a resolver o problema. O arquivo é o SGICS.ini. [SGI51] DriverName=Interbase BlobSize=-1 CommitRetain=False Database=master:D:\SGI\DADOS\SGI.GDB ErrorResourceFile= LocaleCode=0000 Password=masterkey ServerCharSet=Win1252 SQLDialect=3 Interbase_TransIsolation=ReadCommited User_Name=sysdba WaitOnLocks=True Trim Char=False [FOTOS] CaminhoFotos=\\MASTER\D\SGI\FOTOS [COPIA] Database=C:\SISTEMAS\SGI\Dados\numero\SGI.dsv
  4. Deu o mesmo erro. Pelo que estou entendendo da mensagem de erro, que citei na resposta anterior, ela está dizendo que o Usuário e a Senha não estão definidos. Ele pede no final da mensagem para: " Ask your Database Administrator to set up a firebird login", ou seja, para definir um login. Acho que seria isso que eu precisava fazer. Definir o login e senha que parecem não existir, e aí sim testar o arquivo acima com a edição que você sugeriu de senha 12345.
  5. É a versão que é compatível com o programa utilizado na imobiliária. Testei aqui a versão 2.5 que também está no site do firebird disponível e o erro muda. Ele diz que não foi possível conectar ao bando de dados. Já havia visto isso no passado e se não me engano decorre do fato de que a versão 1.5 não exigia senha e a versão 2.5 exige. Não sei como resolver se for usar a versão 2.5 também. O único arquivo de configuração do programa da imobiliária que costumo mexer é o SGI.INI que está com a configuração:
  6. A opção de compatibilidade parece não existir mais. Cliquei com botão direito no .EXE, propriedades, olhei todas as abas e opções e não existe mais aquela opção de selecionar compatibilidade e escolher a versão do Windows para abrir. De todo jeito me parece um bloqueio e isso não seria afetado por modo de compatibilidade de execução. De todo jeito não consigo tentar o que pediu.
  7. Olá. Fiz a atualização do Windows 10 da empresa pro Creators e durante a atualização ele desinstalou o principal programa que utilizamos, uma versão antiga do Firebird. Além de desinstalar sem autorização, ele também agora bloqueia a reinstalação. Eu já fui em CONFIGURAÇÕES -> APLICATIVOS e a opção que estava já selecionada era a correta: PERMITIR APLICATIVOS DE QUALQUER LUGAR. Portanto, meu Windows não está com nenhuma restrição quanto a instalação de programas apenas da Microsoft Store, portanto, o bloqueio não deveria estar ocorrendo. Como eu posso resolver este problema e reinstalar o programa que preciso? Tenho urgência em resolver isso.
×