Conteúdo: Default Ardósia Uva Barbie Morango Pôr do sol Banana Folha Chocolate Madeira
Fundo: Default Ardósia Uva Barbie Morango Pôr do sol Banana Folha Chocolate Madeira
Desenho: Liso Onda Linha Retalho Madeira Rocha Couro Colméia Vertical Triângulo

Arquivado

Este tópico foi arquivado e está fechado para novas respostas.

riba2007

ComboBox - Excel 2007

6 posts neste tópico

Amigos


Preciso colocar um combobox em uma planilha do excel, onde este combo teria o nome de itens e produtos. Quando o usuário escolher um dos produtos, o valor unitário deste produto seria colocado em uma celula (preco unitário).


O combo seria:


1 -  Produto1


2 - Produto2


3 - Produto 3


Escolhendo um dos itens acima, o valor correspondente a este item seria colocado em uma celula. Depois eu faria as operaçoes básicas de quant. x preço unit = preço total.


Obrigado pela ajuda.

0

Riba

Compartilhar este post


Link para o post
Compartilhar em outros sites

ae Riba,

seguinte... vi o que você quer e montei uma formula para você... só que a formula só aceita no máximo 7 SE, ou seja, 7 produtos. Se for mais que isso, melhor usar outro metodo... nesse caso, não poderei mais te ajudar... rsrs

bom, pro Combobox, faz o seguinte: cria, em uma parte da planilha que não vai ser impressa uma lista com os produtos. tipo: em H1 Produto1, H2 produto2... H5 produto5. depois, você vai na celula onde o Combobox vai ser feito. Ex: A1. Clica no Menu Dados - Validação - em configurações, escolha Lista em permitir, e em origem você vai inserir os campos que você digitou os produtos... no meu exemplo seria H1:H5 (Clicando no quadrado ao lado, você pode selecionar direto na planilha); depois é só dar Ok.


bom, digamos que você tenha feito o combo na celula A1. Na celula que você quer que apareça o valor do produto, digite o seguinte: =SE(A1="Produto1";1;SE(A1="Produto2";2;SE(A1="Produto3";3;SE(A1="Produto4";4;SE(A1="Produto5";5;SE(A1="Produto6";6))))))

repare que ao lado do produto, tem um número (1 a 6) que vai ser o valor do produto em questao.


espero ter ajudado.


um abraço

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro Maciel


Boa noite. Perfeito sua dica. Os meus itens são na realidae 7. Funcionou muito bem.


Obrigado, fico de devendo essa.


Ribeiro



Data: 6/5/2007 3:07:22 PM
Autor: lmacields


ae Riba,

seguinte... vi o que você quer e montei uma formula para você... só que a formula só aceita no máximo 7 SE, ou seja, 7 produtos. Se for mais que isso, melhor usar outro metodo... nesse caso, não poderei mais te ajudar... rsrs

bom, pro Combobox, faz o seguinte: cria, em uma parte da planilha que não vai ser impressa uma lista com os produtos. tipo: em H1 Produto1, H2 produto2... H5 produto5. depois, você vai na celula onde o Combobox vai ser feito. Ex: A1. Clica no Menu Dados - Validação - em configurações, escolha Lista em permitir, e em origem você vai inserir os campos que você digitou os produtos... no meu exemplo seria H1:H5 (Clicando no quadrado ao lado, você pode selecionar direto na planilha); depois é só dar Ok.


bom, digamos que você tenha feito o combo na celula A1. Na celula que você quer que apareça o valor do produto, digite o seguinte: =SE(A1=''Produto1'';1;SE(A1=''Produto2'';2;SE(A1=''Produto3'';3;SE(A1=''Produto4'';4;SE(A1=''Produto5'';5;SE(A1=''Produto6'';6))))))

repare que ao lado do produto, tem um número (1 a 6) que vai ser o valor do produto em questao.


espero ter ajudado.


um abraço

0

Riba

Compartilhar este post


Link para o post
Compartilhar em outros sites

tamo ae para isso... as  vezes acertamos... rs


vlw

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

E se eu quiser preencher um combobox em um userform a partir de registros de uma base sql server?

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

me ajudou muito a sua dica... Grande Abraço.

0

Compartilhar este post


Link para o post
Compartilhar em outros sites


O site BABOO está no ar para informar e ajudar o internauta de Windows. Este site foi publicado em 1999 por Aurélio "Baboo", engenheiro e um dos maiores especialistas brasileiros em Windows, que trabalha profissionalmente com esse sistema operacional desde 1987. Desde 2004 ele é premiado anualmente pela Microsoft como MVP (Most Valuable Professional) pela sua contribuição e ajuda à comunidade de usuários de Windows.

Em 2001 foi criado o
Fórum do BABOO para ajudar o internauta brasileiro a solucionar problemas e dúvidas sobre Windows, Segurança, Office, Hardware e outros temas. Desde 2010 a Microsoft também tem premiado o Mr.Million, administrador da área de Segurança do Fórum do BABOO, pelo seu incansável trabalho ajudando os internautas a remover vírus e malwares dos seus computadores. Atualmente ele é o único MVP brasileiro de Segurança em desktop.

O BABOO é o único site brasileiro coordenado por um especialista com reconhecimento internacional pela sua competência em Windows e que participa diariamente e ativamente nos comentários e discussões do site e fórum BABOO.