Ir para conteúdo
Entre para seguir isso  
pauloage

EXCEL - soma hora extra

Mensagem Recomendada

Olá. Pessoal "ferras".... Eu to fazendo um relatório de horas-extras Mensal e peguei a planilha sem nem uma função/formular.. ex-funcionario. Ai ja fiz algumas modificações mais ainda num ta 100%. to com dificuldade pq. não consigo colocar as formulas/função com com o valor da hora. Na primeira Planilha2 (SABADO E PRORROGAÇÕES) so preciso ter uma função pra quando por Ex: C9-B9= 11:00 "ou mais 12:00,13:00" Hs subitrair 01:00 (uma Hora) de Almoço. BLZ.. Já na Planilha3 (DEMONSTRATIVO) não ta dano certo na celular AJ22 "=SOMA(H22:AI22)" tenho que colocar o numero 1 corresponde a (1:00) nas celulas correspondentes ao tanto de hora trabalhada naquele dia" será que é por isso que a formular não funcionar? E será que tem como a planilha2 ser preenchida automaticamente? conforme vou preenchendo a Planilha2? Amigos no meu Carnaval tive que da uma repaginada nesta planilha e não conseguir.! preciso de ajudem.. Help... Vai Planilha no anexo!!

CONTROLE DIÁRIO DE HORAS EXTRAS - SÁBADOS E PRORROG. DE SERVIÇOS POR SERVIDOR FEVEREIRO - 2011.zip

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa tarde Paulo

Na Aba Demosntrativo, para não aparecer aquele #N/D, copie e cole em B3 a seguinte fórmula =SE(A3="";"";PROCV(A3;FUNCIONARIOS!$A$3:$B$72;2;FALSO)) e depois arraste para as outras linhas.

Na mesma Aba na célula AJ16, basta dividir por 24, copie e cole a seguinte fórmula =SOMA(H16:AI16)/24

Para que as horas seja lançadas automaticamente nas devidas datas, basta vc coloca um igual na célula da planilha Demonstrativo e clicar na célula que vc quer copiar os dados da planilha SÁBADOS e PRORROGAÇÃO.

Só falta resolver o problema da subtração. Vou tentar se conseguir posto depois.

Dê retorno.

Um abraço.


Patropi - Moderador

Compartilhar este post


Link para o post
Compartilhar em outros sites

Nossa.. H-lera aqui é rapida!

Valeu..Grande resolvido 75% do Problemar.. Valeu mesmo! deu tudo certo....aqui......... genial as suas alternativas pra resolver

Editado por pauloage

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite!

Tem uma solução bem simples!

Escolha por exemplo qualquer coluna, digamos a G2.. coloque nela 1:00 , agora na coluna D onde esta o caculo das horas faça o seguinte coloque esta função :=SOMA(C5-B5-$G$2) e arraste..

Assim no final do total vai ser sempre diminuídas 1 :00 de intervalo!!

Espero ter ajudado..

Editado por marcelokai

O truque da filosofia é começar por algo tão simples que ninguém ache digno de nota e terminar por algo tão complexo que ninguém entenda.

16659376348_0bf967577c_s.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites

Grande.. Marcelokai!! olá você ja me ajudou em uma outra planilha "SAIDA POR EQUIPE"..lembra? grande trabalho o seu...

assunto1:

Voltando!.. o Problema é o seguinte so preciso subitrair 1:00 Hs quando o subitração der um resultado maior quer 10:00 exemplo C5=7:00 - B5=18:00 o resultado vai ser 11:00 mais preciso tirar 1:00 Hs do ALmoço desse resultado... os demais não precisa mexe....valeu... do modo que você disse ta tirando uma hora da soma total!..valeu..

assunto2:

MarceloKai.. queria te perguntar outra coisa..

Construir um Planilha aqui ... e fiz uma Macro pra copiar algumas celulas de uma Planilha1 pra outra Planilha2, Blz.. até ai.., mas, queria saber se tem como essa Colar não levar. as Funções.. por exemplo tem a Função =hoje().. ai ja viu a data sempre fica atualizada tanto na Planilha1 como na Planilha2.. queria que ficasse apenas atualizada na planilha1.. queria que nenhum Função fosse para a Planilha2 so os resultados.. Valeu Marcelo entendeu? Posso te pedir outra ajudinha? Boa sorte.....

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia !

Mourense, do jeito que você colocou na formula na coluna (D) , se ultrapassar 10:00 então ficara somente 10:00? ele vai parar de calcular.. ou seja não está descontando uma hora..

bom foi isso que eu entendi .. posso estar errado, mas acho que não vai atender ao quesito da planilha do Paulo.

estou postado em anexo a que eu fiz .. veja se é isso.

TESTE_BABOO.zip

Editado por marcelokai

O truque da filosofia é começar por algo tão simples que ninguém ache digno de nota e terminar por algo tão complexo que ninguém entenda.

16659376348_0bf967577c_s.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia Marcelokai

Sim a fórmula que eu fiz é para isso mesmo, pois pelo que eu entendi ele quer limitar a 10:00 hs.

Veja o trecho que ele escreveu de onde eu cheguei a essa conclusão:

"quando o subitração der um resultado maior quer 10:00 exemplo C5=7:00 - B5=18:00"

Pode ser que eu interpretei errado. Sei lá... é complicado interpretar...

Um abraço.


Patropi - Moderador

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Entre para seguir isso  

×