Este fórum foi descontinuado. LEIA AQUI e participe da Comunidade BABOO :)

Ir para conteúdo
renatoooooo

Formula SE(E Retornando "FALSO"

Mensagem Recomendada

Bom dia pessoal,

Estou com um problema nesta formula: =+SE($C13="";0;SE(E($C13=K$12;$B13<=$B$3);SE($D13="Despesa";-$H13;SE($D13="Receita";$H13;0))))

Resumindo, esta celula que é do banco Bradesco, recebe o valor da despesa ou receita quando na coluna "C" eu seleciono o banco Bradesco, o valor também é lançado negativo caso na coluna "D" esteja marcado como "Despesa" e positivo caso seja "Receita", se eu selecionar Poupança ela vai pro "Banco Poupança" e assim por diante, porém estou com um problema que quando o dinheiro vai pra um banco os outros dão como resposta "FALSO" e eu gostaria que aparecesse "0,00" ao invés de falso. Ja tentei de tudo e não consegui!

Antes eu não tinha na formula a opção de se for "Despesa" lançar negativo e se for "Receita" positivo e não dava este erro.

Muito obrigado pela atenção.

Att

Renato

Compartilhar este post


Link para o post
Compartilhar em outros sites

analisando sua fórmula, existe um SE sem a atribuição do que fazer quando for FALSO (destacado em vermelho):

=SE($C13="";0;SE(E($C13=K$12;$B13<=$B$3);SE($D13="Despesa";-$H13;SE($D13="Receita";$H13;0));"seu valor aqui...."))

como não atribuiu nada, o excel retorna FALSO.

Compartilhar este post


Link para o post
Compartilhar em outros sites

em vermelho.....

=SE($C13="";0;SE(E($C13=K$12;$B13<=$B$3);SE($D13="Despesa";-$H13;SE($D13="Receita";$H13;0));0))

Editado por /alexandre_eng/

Compartilhar este post


Link para o post
Compartilhar em outros sites

Muitíssimo obrigado Alexandre, ontem fiquei horas tentando descobrir onde estava o problema e em minutos você me ajudou de maneira muito eficiente!

***PROBLEMA RESOLVIDO***

Att

Renato Romero

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom Dia, pessoal gostaria de uma ajuda, estou criando uma planilha e não tenho muito conhecimento com formulas, eu estava tentando usar a formula SE, para se o gasto for maior que o valor que tenho disponível jogar na célula falta o valor de quanto está faltando e se o valor de gasto for menor que o disponível jogar na célula sobra o valor que está sobrando, poderiam me ajudar por favor?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obrigado osvaldomp!

 

Minha planilha está assim. 

Faltando B21

Sobrando B22

a formula deixei assim

=SE(B21>=B22;"Sobrando"&B21-B22;"Faltando"&B21-B22)

está correto? pois aparece #VALOR

Compartilhar este post


Link para o post
Compartilhar em outros sites

A sua fórmula está correta, provavelmente você colocou texto em B21 e ou B22, por isso a fórmula retorna o erro #VALOR.

Em B21 e em B22 coloque apensas os valores, exemplos: 40,26 ou 125,89.


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

×
×
  • Criar Novo...