Conteúdo: Default Ardósia Uva Barbie Morango Pôr do sol Banana Folha Chocolate Madeira
Fundo: Default Ardósia Uva Barbie Morango Pôr do sol Banana Folha Chocolate Madeira
Desenho: Liso Onda Linha Retalho Madeira Rocha Couro Colméia Vertical Triângulo

Arquivado

Este tópico foi arquivado e está fechado para novas respostas.

Melqyahd

Entradas USB não funcionam

16 posts neste tópico

Olá, pessoal!

Estou num ímpasse. As entradas USB de um computador deixaram de funcionar... Sempre que se pluga um pendrive (que noutro computador funcione normalmente), o Windows apresenta a mensagem de dispositivo não reconhecido - isto em qualquer entrada USB, mesmo nas entradas do mouse, teclado ou webcam que, por sua vez, ainda que sejam USB, funcionam. Tentei atualizar o chipset, desabilitar e reabilitar as funções USB na BIOS, reconectar os cabos do painel frontal... mas nada disso funcionou. Alguém sabe o que pode-se fazer para que as entradas funcionem?

Anexei as especificações do computador.

Grato,

Melqyahd M.

Report.zip

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá Melqyahd ,

Iniciar / Executar / Regedit / <Ok>

HKEY_LOCAL_MACHINE / SYSTEM / CurrentControlSet / services / USBSTOR /

Procure do Lado direito por "Start" , clique duas vezes e Altere o valor para 3

Feche o Regedit e Reinicie a Máquina

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá, Silver.Lord. Obrigado pela resposta!

Bem, o computador é de um amigo e não está aqui neste momento... se esta dica não funcionar, o que mais poderia ser feito? Li em algumas páginas around the web que algumas entradas não funcionavam porque a fonte não as conseguia alimentar com energia suficiente. Será possível, neste caso?

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Esqueci-me de mencionar que a própria fase de POST tem dificuldade em reconhecer os pendrives, ainda que um destes contenha informações de boot. Estive a pesquisar e localizei algumas possíveis soluções. Porém, ainda assim, gostaria de saber mais daqui. Alguém possui mais alguma sugestão?

Melqyahd M.

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sugestão:

Desabilitar o gerenciamento de energia das USB No BIOS.

Mudar de posição os jumpers de energia das portas USB na placa-mãe, normalmente identificadas como PWR_USB

0

Intel I7 920 @ 1,99 ~ 3,48 GHz -- 6GB RAM -- GA-EX58-UD4P -- AMD HD 7750 (1GB/DDR5/128bits) -- 3,5 TB HD + 80 GB SSD Intel -- Corsair TX650 -- W7 64
Fusion E-350 @ 0,8 ~ 1,6 GHz -- 6GB RAM -- HP DM1-3250br -- AMD HD 6310 (384mb APU) -- 320 GB HD -- Bateria 6 células 55 W/h -- W7 64

Compartilhar este post


Link para o post
Compartilhar em outros sites

nunca fui atras de descobrir o q esses jumpers fazem

pra mim tinha algo a ver com acordar o PC da hibernacao ou outro estado de economia, por algum dispositivo plugado na porta usb

0

VB.Net & C#

Compartilhar este post


Link para o post
Compartilhar em outros sites

Sim, isso mesmo, e em alguns equipamentos isso causa problemas com as USB.

0

Intel I7 920 @ 1,99 ~ 3,48 GHz -- 6GB RAM -- GA-EX58-UD4P -- AMD HD 7750 (1GB/DDR5/128bits) -- 3,5 TB HD + 80 GB SSD Intel -- Corsair TX650 -- W7 64
Fusion E-350 @ 0,8 ~ 1,6 GHz -- 6GB RAM -- HP DM1-3250br -- AMD HD 6310 (384mb APU) -- 320 GB HD -- Bateria 6 células 55 W/h -- W7 64

Compartilhar este post


Link para o post
Compartilhar em outros sites

Testei estas e outras possíveis soluções, mas infelizmente nenhuma funcionou. Tentei, não exatamente nesta ordem:

-----------------------------------------------------------------------------------------------------------

Regedit:

HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/USBSTOR/

Alterar a chave "Start" para "3"

Reiniciar a máquina

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Fazer uma reparação do Windows com o disco do w7 x64

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Deletar as entradas USB no Gerenciador de Dispositivos, em Safe Mode, ref. à USB Root Hub

Caso necessário, refazer a reparação do Windows com o disco do w7 x64

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

No CMD, como administrador, digitar:

set devmgr_show_nonpresent_devices=1 <Enter>

start devmgmt.msc <Enter>

Lidar com os periféricos em questão (entradas USB)

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Regedit:

Clicar sobre COMPUTER (primeira opção)

Fazer backup do registro

HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/Class/{36FC9E60-C465-11CF-8056-444553540000}

Deletar as chaves "UpperFilters" e "LowerFilters"

Reiniciar o computador

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Criar um novo perfil de usuário, reiniciar o computador e testar as entradas

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Habilitar a USB Legacy na BIOS e testar as entradas

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Copiar os arquivos "USBSTORE.INF", "USTSTORE.INF" e "USBSTORE.SYS" do diretório C:\Windows\System32\DriverStore\FileRepository\usbstor.inf(...)

Colá-los no diretório C:\Windows\Inf (antes, realizar uma cópia dos originais)

Ir ao gerenciador de dispositivos, no ícone amarelo (com problema) e mandar reinstalar o driver, a procurar no diretório C:\Windows\Inf

Se não funcionarem os passos anteriores da questão 9:

Colar o arquivo "USBSTOR.SYS" no diretório C:\Windows\System32\drivers (antes, realizar uma cópia do original)

Reiniciar o computador e testar pelo gerenciador de dispositivos a atualizar o driver do pendrive em questão

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Tentar resetar a BIOS

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Tentar o FixIt (primeiro, o portável) da Microsoft

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Atualizar a BIOS

Reinstalar os drivers do chipset

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Remover a fonte e deixar 10~15 minutos desconectado. Reconectar, e testar

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

No CMD, digitar:

sfc /scannow <Enter>

Analisar o log de resultado, criando um novo arquivo no CMD, ao digitar:

findstr/c:"[sR]" %windir%\logs\cbs\cbs.log > sfcdetails.txt

Então, rodar o chkdsk após reiniciar o computador

Por último, executar o passo 3 e reiniciar o computador

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Atualizar o driver de vídeo da nVidia (geforce.com/drivers)

Modelo: GeForce 8400 GS

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Tentar o FixIT da MS ref. ao nVidia USB Problem

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Mudar as configurações de energia, a desabilitar especialmente o desligamento seletivo da USB

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Tentar isto: http://support.microsoft.com/kb/817900/pt-br

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Desabilitar o gerenciamento das USB na BIOS

Mudar de posição os jumpers das portas USB na mobo, normalmente identificadas como PWR_USB

-----------------------------------------------------------------------------------------------------------

Além destes, tentei outros HotFixes, FixIt e KB's da Microsoft, mas todos em vão. Pretendo ainda testar um LiveCD para conferir se funcionam as entradas USB nestes, e também por outras entradas na mobo dele. Alguém tem mais alguma ideia?

Melqyahd M.

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá, pessoal! Como estais?

Testei mais alguns KB's, fixes e afins, além do que se segue - e nada funcionou:

-------------------------------------------------------------------------------------------------------

Executar -> Dismgmt.msc <Enter> /ou/ Clicar com o botão direito sobre "Computador" -> Gerenciar -> Gerenciador de discos

Localizar o pendrive

Atribuir nova letra de unidade ao pendrive

=-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-==-==-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Testar os três novos KB's que descarreguei da MS

=-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-==-==-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Testar o LiveCD do Ubuntu

=-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-==-==-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Tentar o FixIT Beta da MS

=-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-==-==-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Na raiz do disco, criar um diretório nomeado usbdriver

Copiar todos os arquivos de %windir%\inf para o diretório criado

Tentar atualizar o driver do mass storage usando o caminho do diretório criado

=-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-==-==-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Copiar e colar o arquivo "[original] usbstor.inf" em %windir%\inf

Desinstalar os USB não reconhecidos

Replugá-los

=-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-==-==-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Entrar em modo seguro do Windows

Deletar os arquivos "disk.sys" e "partmgr.sys" do diretório %windir%\system32\drivers

=-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-==-==-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Tentar o USB.bat

=-=-=-=-=-=-=-=-=-=-=-==-=-=-=-=-==-==-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=

Desinstalar os controles USB (USB hubs)

Tentar retirar e repor a bateria da BIOS

Aguardar 5 minutos

-------------------------------------------------------------------------------------------------------

.

.

O curioso é que no Linux todas as entradas USB funcionaram (tanto as frontais quanto as traseiras). Porém, agora tenho dois problemas.

1-) O mouse e teclado USB funcionam até no momento do boot, post. Já os pendrives não, mas por que então funcionam no Linux e no Windows não?

2-) Tentei reinstalar o Windows (utilizando um DVD), e logo no começo, durante a cópia dos arquivos para a instalação, ocorreu o erro: 0xc00000e9 e não pude prosseguir. Então, tentei plugar o pendrive e dar boot na instalação do Windows por ele, e funcionou. A instalação copiou os arquivos e, ao aparecer a interface de cor azul [não a de erro, mas a de instalação], travou e não mais prosseguiu. Tive de retirar o pendrive, e depois não mais consegui dar boot nele. O CD continou a apresentar o mesmo erro.

O que pode estar a se passar neste PC?

Grato,

Melqyahd M.

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Dado que o linux utiliza drivers genericos para as USB suponho que exista um problema de driver.

Tente no gerenciador de dispositivos desativar o USB 2.0 e em seguida teste a conexão com pendrive's . A conexão deve ocorrer via controladora USB 1.1.

Faça o mesmo com as controladoras 1.1, desative-as e teste a conexão com pendrives. A conexão deve ocorrer via controladora USB 2.0.

Tente verificar no site da placa-mãe se há alguma atualização para CHIPSET ou para USB.

0

Intel I7 920 @ 1,99 ~ 3,48 GHz -- 6GB RAM -- GA-EX58-UD4P -- AMD HD 7750 (1GB/DDR5/128bits) -- 3,5 TB HD + 80 GB SSD Intel -- Corsair TX650 -- W7 64
Fusion E-350 @ 0,8 ~ 1,6 GHz -- 6GB RAM -- HP DM1-3250br -- AMD HD 6310 (384mb APU) -- 320 GB HD -- Bateria 6 células 55 W/h -- W7 64

Compartilhar este post


Link para o post
Compartilhar em outros sites

srlan,

Obrigado pela ajuda. De fato, sua ideia funcionou! Quando desativo o controlador USB 2.0 no gerenciador de dispositivos, os demais funcionam - inclusive o que é 2.0, em legacy - na velocidade do 1.1. Porém, tentei atualizar o Chipset e ainda não funcionou o 2.0 quando habilitado. Quando ele está habilitado, nenhuma das entradas funciona. Tentei trocar a entrada por uma nova, e então funcionou. Será que só resolverá se ele comprar um novo controlador USB 2.0?

Quanto ao erro no momento da instalação do Windows, ainda ocorre (0xC00000e9 - erro de E/S). Testei com outro drive e o erro persiste. Creio que seja erro na gravação do DVD, neste caso.

Cordialmente,

Melqyahd M.

0

Compartilhar este post


Link para o post
Compartilhar em outros sites


O site BABOO está no ar para informar e ajudar o internauta de Windows. Este site foi publicado em 1999 por Aurélio "Baboo", engenheiro e um dos maiores especialistas brasileiros em Windows, que trabalha profissionalmente com esse sistema operacional desde 1987. Desde 2004 ele é premiado anualmente pela Microsoft como MVP (Most Valuable Professional) pela sua contribuição e ajuda à comunidade de usuários de Windows.

Em 2001 foi criado o
Fórum do BABOO para ajudar o internauta brasileiro a solucionar problemas e dúvidas sobre Windows, Segurança, Office, Hardware e outros temas. Desde 2010 a Microsoft também tem premiado o Mr.Million, administrador da área de Segurança do Fórum do BABOO, pelo seu incansável trabalho ajudando os internautas a remover vírus e malwares dos seus computadores. Atualmente ele é o único MVP brasileiro de Segurança em desktop.

O BABOO é o único site brasileiro coordenado por um especialista com reconhecimento internacional pela sua competência em Windows e que participa diariamente e ativamente nos comentários e discussões do site e fórum BABOO.