Ir para conteúdo
  • Cadastre-se

A partir do dia 19/11/2018, o foco do Fórum do BABOO é apenas Windows e Segurança Digital conforme informado no início de 2018.
As áreas que não têm relação com esses dois assuntos foram arquivadas e seus tópicos estão disponíveis para consulta na área Tópicos Antigos.

Conheça as novidades de 2019 para o BABOO e Fórum do BABOO

Newton Motta

EXCEL - Fugindo de Referência Circular

Mensagem Recomendada

Oá amigos,

 

Tenho a planilha EXCEL abaixo onde um funcionário tem uma dívida de R$ 284,00 de possível desconto de suas despesas médicas, porém os descontos estão limitados a um valor total XT= R$ 150,00, que é 10% do valor de seu salário de R$ 1.500,00.

 

Sendo assim, tem como eu formular a planilha de modo a fugir de uma referencia circular?

 

SALÁRIO DO FUNCIONÁRIO= R$ 1.500,00

VALOR TOTAL XT = R$ 150,00 OU SEJA 10% DO SALÁRIO.

 

           Coluna A                                Coluna B

DESCONTO PREVISTO          DESCONTO REAL APLICADO

R$      100,00                                      x1  

R$        75,00                                      x2  

R$        30,00                                      x3  

R$        70,00                                      x4

R$           9,00                                     x5

R$       284,00                                     XT

 

Grato se puderem me ajudar.

 

abrs

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Referência circular?

para calcular o desconto a ser aplicado:
=SE(salário*0,1>=despesas;despesas;salário*0,1)



exemplo:
salário em 'C3' e depesas médicas em 'D3', utilize:
=SE(C3*0,1>=D3;D3;C3*0,1)
 


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
Referência circular?

para calcular o desconto a ser aplicado:

=SE(salário*0,1>=despesas;despesas;salário*0,1)

exemplo:

salário em 'C3' e depesas médicas em 'D3', utilize:

=SE(C3*0,1>=D3;D3;C3*0,1)

Prezado Osvaldo,

Agradeço muito o seu interesse, porém talvez eu não tenha feito me entender. A sua fórmula está correta para uma aplicação diferente da minha.

Veja bem:

Durante o mes 1 funcionário teve 5 itens de despesas médicas que totalizaram R$ 284,00, porém a soma de x1:x5 só pode ser R$ 150,00 que é o salário*0,1. Se voce envolver a célula que contém XT na fórmula voce incorrerá numa referência circular. Eu resolvi de uma maneira simplória utilizando XT = R$ 150,00 dividido pelo numéro de itens, no caso 5. Isso resultou em um desconto linear de R$ 30,00 por item. Sendo assim a diferença entre a coluna A e a coluna B, trará alguns resultados negativos, como por exemplo o item 5: R$ 9,00 - R$ 30,00  igual a  - R$ 21,00.

O que procuro é uma maneira de descontar de cada item um valor compatível que não me traga uma diferença negativa.

Isso está um tanto quanto complicado, mas é um bom exercício.

Um grande abraço,

Newton

Editado por Newton Motta

''

Compartilhar este post


Link para o post
Compartilhar em outros sites
O que procuro é uma maneira de descontar de cada item um valor compatível ...

 

 

Fala, Newton.

E o que seria 'um valor compatível' ?

 

 

uma forma de calcular o "valor compatível" é com base na proporcionalidade salário*0,1/despesas, assim:

considerando:

1. desconto previsto a partir de 'A2'

2. desconto aplicado a partir de 'B2' (veja a fórmula abaixo)

3. salário em 'C3'

4. total das depesas em 'D3'

cálculo de X1, X2, ..., X5:

em 'B2' coloque  =A2*SE($C$3*0,1>=$D$3;1;$C$3*0,1/$D$3) e arraste para baixo

 


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
Fala, Newton.

E o que seria 'um valor compatível' ?

 

 

uma forma de calcular o "valor compatível" é com base na proporcionalidade salário*0,1/despesas, assim:

considerando:

1. desconto previsto a partir de 'A2'

2. desconto aplicado a partir de 'B2' (veja a fórmula abaixo)

3. salário em 'C3'

4. total das depesas em 'D3'

cálculo de X1, X2, ..., X5:

em 'B2' coloque  =A2*SE($C$3*0,1>=$D$3;1;$C$3*0,1/$D$3) e arraste para baixo

 

Prezado Osvaldo.

 

Perfeito, bateu com o que eu desejava.

 

Parabéns e um abraço,

 

Newton

Compartilhar este post


Link para o post
Compartilhar em outros sites

×