Ir para conteúdo
Entre para seguir isso  
Vereda

EXCEL - Atribuir valor numérico a uma palavra

Mensagem Recomendada

Olá a todos.

Tenho uma tabela com resultados de provas escolares, onde surge a palavra «desistiu» no lugar de alguns resultados. No entanto, quando faço a média aritmética, apenas são considerados os resultados numéricos. O que eu queria era atribuir 0,0 à palavra «desistiu», fazendo com que a média considerasse também o número de vezes [ou de zeros] que a palavra surge nos resultados.

Será que alguém me sabe ajudar?

Aguardo com enorme expectativa pelas vossas sugestões.

Obrigado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá Vereda, boa tarde!

 

Pensei em duas sugestões:

 

1) Pensando que o intervalo em que estão as notas é de B2 até B10 sugiro o seguinte:

 

Ao invés de simplesmente fazer a fórmula =MÉDIA(B2:B10) faça a média da seguinte fórmula:

 

=SOMA(B2:B10)/CONT.VALORES(B2:B10)

 

Dessa maneira, somamos todas as notas numéricas, e dividimos pelo número de células numéricas ou com o texto desistiu.

 

ou

 

2) Utilizar o CTRL + L, clicar em substituir

 

Localizar os textos «desistiu» e substituir por 0,00.

 

Se não ajudar, se for  possível posta a planilha para nós, no formato "ZIP" (clica com botão direito no arquivo, Enviar para "Pasta Compactada").

 

Aguardamos teu retorno.

 

Abraço.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá VEREDA,

 

Faça alguns testes com a seguinte fórmula:

 

=MÉDIAA(B2:B20)

 

e verifique se resolve o seu problema.

 

Markmzz

Editado por markmzz

''

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá Vereda, a fórmula sugerida pelo MARKMZZ acredito que dá certo.

 

Pelo que entendi de sua planilha, quando o aluno "faltou" é necessário não entrar na média.

Dessa forma, utilize essa fórmula:

 

=SOMA(B2:B10)/(CONT.VALORES(B2:B10)-CONT.SE(B2:B10;"faltou"))

 

Abraço.

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

Já entendi porque a sugestão do DIGNUSI não funcionava. O idioma do meu Excel só aceita desta forma:

=SOMA(B2:B10)/(CONTAR.VAL(B2:B10)-CONTAR.SE(B2:B10;"faltou"))

 

Obrigado a todos pela preciosa ajuda. Esta coisa dos fóruns é uma maravilha. Agora já sei a quem recorrer quando surgir mais algum problema.

Aquele abraço!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Entre para seguir isso  

×