Conteúdo: Default Ardósia Uva Barbie Morango Pôr do sol Banana Folha Chocolate Madeira
Fundo: Default Ardósia Uva Barbie Morango Pôr do sol Banana Folha Chocolate Madeira
Desenho: Liso Onda Linha Retalho Madeira Rocha Couro Colméia Vertical Triângulo
Bem-vindo ao Fórum do BABOO!

Desde 2000 o Fórum do BABOO tem ajudado milhões de internautas de Windows a resolverem seus problemas e dúvidas, além de ajudar na remoção de vírus e malwares de seus computadores. Somos o único fórum brasileiro coordenado por um especialista com reconhecimento internacional pela sua competência em Windows, então se você tem uma dúvida ou problema que nenhum outro fórum resolve, poste-a aqui pois o MVP Babooadora desafios!
  

O Fórum do BABOO também conta com a participação exclusiva do administrador da área de Segurança MVP Mr.Million que tem reconhecimento internacional da Microsoft pelo seu incansável trabalho ajudando os internautas a remover vírus e malwares dos seus computadores. Se o seu computador está infectado por algum vírus, ele te ajudará a removê-lo!
  

Nosso time de especialistas também inclui Patropi  Osvaldomp  Caze  Ciro-Mota  XERLOUCO ROUMS  Tatha que responderão suas dúvidas sobre diversos assuntos.
 

Participe da nossa comunidade! 

 

Entre para seguir isso  
Seguidores 0
Vereda

EXCEL - Atribuir valor numérico a uma palavra

9 posts neste tópico

Olá a todos.

Tenho uma tabela com resultados de provas escolares, onde surge a palavra «desistiu» no lugar de alguns resultados. No entanto, quando faço a média aritmética, apenas são considerados os resultados numéricos. O que eu queria era atribuir 0,0 à palavra «desistiu», fazendo com que a média considerasse também o número de vezes [ou de zeros] que a palavra surge nos resultados.

Será que alguém me sabe ajudar?

Aguardo com enorme expectativa pelas vossas sugestões.

Obrigado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá Vereda, boa tarde!

 

Pensei em duas sugestões:

 

1) Pensando que o intervalo em que estão as notas é de B2 até B10 sugiro o seguinte:

 

Ao invés de simplesmente fazer a fórmula =MÉDIA(B2:B10) faça a média da seguinte fórmula:

 

=SOMA(B2:B10)/CONT.VALORES(B2:B10)

 

Dessa maneira, somamos todas as notas numéricas, e dividimos pelo número de células numéricas ou com o texto desistiu.

 

ou

 

2) Utilizar o CTRL + L, clicar em substituir

 

Localizar os textos «desistiu» e substituir por 0,00.

 

Se não ajudar, se for  possível posta a planilha para nós, no formato "ZIP" (clica com botão direito no arquivo, Enviar para "Pasta Compactada").

 

Aguardamos teu retorno.

 

Abraço.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá Vereda, a fórmula sugerida pelo MARKMZZ acredito que dá certo.

 

Pelo que entendi de sua planilha, quando o aluno "faltou" é necessário não entrar na média.

Dessa forma, utilize essa fórmula:

 

=SOMA(B2:B10)/(CONT.VALORES(B2:B10)-CONT.SE(B2:B10;"faltou"))

 

Abraço.

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

Já entendi porque a sugestão do DIGNUSI não funcionava. O idioma do meu Excel só aceita desta forma:

=SOMA(B2:B10)/(CONTAR.VAL(B2:B10)-CONTAR.SE(B2:B10;"faltou"))

 

Obrigado a todos pela preciosa ajuda. Esta coisa dos fóruns é uma maravilha. Agora já sei a quem recorrer quando surgir mais algum problema.

Aquele abraço!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Quer postar a sua dúvida? Cadastre-se pois é rápido e fácil!


Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.


Entrar Agora
Esse tópico é útil para você?
Então compartilhe e ajude outros internautas!
Entre para seguir isso  
Seguidores 0

O site BABOO está no ar para informar e ajudar o internauta de Windows. Este site foi publicado em 1999 por Aurélio "Baboo", engenheiro e um dos maiores especialistas brasileiros em Windows, que trabalha profissionalmente com esse sistema operacional desde 1987. Desde 2004 ele é premiado anualmente pela Microsoft como MVP (Most Valuable Professional) pela sua contribuição e ajuda à comunidade de usuários de Windows.

Em 2001 foi criado o
Fórum do BABOO para ajudar o internauta brasileiro a solucionar problemas e dúvidas sobre Windows, Segurança, Office, Hardware e outros temas. Desde 2010 a Microsoft também tem premiado o Mr.Million, administrador da área de Segurança do Fórum do BABOO, pelo seu incansável trabalho ajudando os internautas a remover vírus e malwares dos seus computadores. Atualmente ele é o único MVP brasileiro de Segurança em desktop.

O BABOO é o único site brasileiro coordenado por um especialista com reconhecimento internacional pela sua competência em Windows e que participa diariamente e ativamente nos comentários e discussões do site e fórum BABOO.