Arquivado

Este tópico foi arquivado e está fechado para novas respostas.

mariaeduardac

EXCEL - Fórmula com células vazia

4 posts neste tópico

Olá,

 

Tenho uma planilha de Controle de Pagamento de NF's para controlar os vencimentos, quando está faltando uma semana ela fica como "à vencer" quando passa da data fica como "atrasado", e assim por diante.

Mas quando eu não preencho à coluna "data de vencimento" a coluna "Situação" fica "#N/D" e a coluna "Dias que faltam para o vencimento" fica "-41674" como se a célula vazia equivalesse a data 00/01/01, assim:

 

Data de vencimento         Situação             Dias que faltam para o vencimento      Data de pagamento

                                          #N/D                                 -41674

 

 

Que fórmula aplico para que enquanto a data não é preenchida as outras colunas não sejam preenchidas??

 

 

TESTE controle notas fiscais.zip

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite Maria Eduarda

 

 

Baixe a planilha e veja se é isto que vc deseja:

 

04_02_14_TESTE controle notas fiscais_Patropi.zip

 

Dê retorno.

 

Um abraço.

 

 


Patropi - Moderador

Se a resposta foi útil, clique na flechinha verde, que fica no canto inferior direito

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá MariaEduardaC,

 

Faça testes com as seguintes fórmulas:

 

Em H5

 

=SE(ÉNÚM(I5);PROC(I5;{-9999;1;8};{"Atrasado ";"À vencer";"Não pago"});I5)

 

Em I5

 

=SE(J5;"Pago";SE(E5;E5-HOJE();""))

 

Markmzz

0

Compartilhar este post


Link para o post
Compartilhar em outros sites

Suas formulas estão corretas só estão incompletas faça o seguinte muito simples fácil e rápido

suponte que os dados estEgem assim:

         

               A                               B                                              C                                               D

1 Data de vencimento         Situação             Dias que faltam para o vencimento      Data de pagamento

2

3

4

 

Na Célula B2 onde se encontra a formula da situação, abra ela e no inicio depois do = coloque:

 

se(A2="";"";

 

nos dias que faltam para vencer a mesca coisa, abra a sua formula depois do = coloque:

 

se(B2="";"";

 

colocando dessa forma estará informando que ando a célula de data não tiver NADA irá aparecer NADA ao contrário fara o calculo que você deseja

 

vai ficar assim na coluna de situação

 

=SE(E5="";"";SE(I5="Pago";"Pago";PROCV(I5;Fórmula!$A$2:$C$4;3)))

 

e assim na coluna de vencimento

 

=SE(E5="";"";SE(J5<>"";"Pago";E5-HOJE()))

0

Compartilhar este post


Link para o post
Compartilhar em outros sites
    • 15 Mensagens
    • 7961 Visualizações
    • 2 Mensagens
    • 60 Visualizações
    • Perim
    • Perim
    • 2 Mensagens
    • 241 Visualizações
    • 2 Mensagens
    • 175 Visualizações
    • 2 Mensagens
    • 270 Visualizações