Este fórum foi descontinuado. LEIA AQUI e participe da Comunidade BABOO :)

Ir para conteúdo
paulorltenorio

Linhas para colunas a cada 3 linhas

Mensagem Recomendada

1 hora atrás, paulorltenorio disse:

Quero que fique da seguinte forma:

A  B  C

D  E  F

H  I  J  G H I

...

 

Cole a fórmula abaixo em qualquer célula vazia, arraste duas células para a direita e em seguida arraste a seleção para baixo.

=ÍNDICE($A$1:$A$1500;(LIN(A1)-1)*3+COLUNA(A1))

obs. se a fórmula retornar #NOME substitua COLUNA por COL


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

A fórmula básica que foi utilizada é ÍNDICE(matriz;linha;coluna). Omitindo-se o parâmetro "coluna", o Excel considera a coluna informada no parâmetro "matriz", no seu caso, a coluna 'A', e a fórmula fica assim: ÍNDICE(matriz;linha)

Então, as fórmulas básicas conforme abaixo, colocadas por exemplo em 'C1:E2', retornarão os valores de A1, A2 e A3 na primeira linha e A4, A5 e A6 na segunda.
C1 =ÍNDICE(A1:A1500;1)........... D1 =ÍNDICE(A1:A1500;2)............ E1=ÍNDICE(A1:A1500;3)
C2 =ÍNDICE(A1:A1500;4)............D2 =ÍNDICE(A1:A1500;5)..............E2 =ÍNDICE(A1:A1500;6)
                
Para facilitar a vida de quem vai instalar as fórmulas, cria-se uma única fórmula que poderá ser arrastada para a direita e para baixo.
1. é preciso travar o intervalo da matriz ---> $A$1:$A$1500    (referência absoluta na coluna e também na linha)            
2. introduz-se a parte que fornece o incremento da linha ao arrastar para baixo, no seu caso o incremento é passo 3, pois a sequência desejada na vertical é 'A1', 'A4', 'A7', ... ---> =(LIN(A1)-1)*3 (esta fórmula arrastada para baixo irá gerar a sequência 0, 3, 6, ... na vertical).            
3. introduz-se a parte que fornece o número da primeira linha desejada da matriz, no seu caso a linha 1, pois interessa retornar inicialmente o valor de 'A1' ---> =(LIN(A1)-1)*3+1 (esta fórmula irá gerar 1, 4, 7, ... na vertical)                
4. substituindo agora o número 1 tratado no item anterior pela função COL(A1) ---> =(LIN(A1)-1)*3+COL(A1), ao ser arrastada para a direita, esse valor será incrementado em 1 a cada coluna (passo 1), e ficará assim =(LIN(B1)-1)*3+COL(B1) ou seja, irá incrementar em 1 a linha retornada, pois no seu caso, interessa buscar o valor de 'A2', e arrastando agora para mais uma coluna a fórmula buscará o valor de 'A3' ---> =(LIN(C1)-1)*3+COL(C1) . Resumindo, esta fórmula arrastada para a direita gera 1, 2 e 3:  =(LIN(A1)-1)*3+COL(A1)        
                
Juntando as partes a fórmula estará assim preparada para ser arrastada para a direita, com passo 1, e para baixo, com passo 3.
=ÍNDICE($A$1:$A$1500;(LIN(A1)-1)*3+COLUNA(A1))                

 


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

×
×
  • Criar Novo...