CONHEÇA o BABOO PRO e a Comunidade BABOO que substituirão o site BABOO e esse fórum

Ir para conteúdo
  • Cadastre-se
Martti

Excel fórmula para converter coordenadas geográficas

Mensagem Recomendada

Prezados senhores,

Conforme a tabela em anexo, necessito de uma fórmula que converta as coordenadas geográficas em graus decimais (UTM)

para coordenadas geográficas (graus, minutos e segundos) nas colunas D e E respectivamente.

Sei que existem planilhas prontas, mas não atendem a minha necessidade pois tenho que condensar planilhas

imensas, sem que estas busquem referências em outras células, abas ou planilhas.

Desde já agradeço a ajuda de todos, como sempre.

Abraço

 

 

SINISTRO_COORDENADAS.xls

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia...

Cara,não sei se é bem isso que você quer...testa ai...

obs: HABILITE MACROS

 

SINISTRO_COORDENADAS.xlsm


O truque da filosofia é começar por algo tão simples que ninguém ache digno de nota e terminar por algo tão complexo que ninguém entenda.

16659376348_0bf967577c_s.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites
5 horas atrás, Marcelo Kai disse:

Bom dia...

Cara,não sei se é bem isso que você quer...testa ai...

obs: HABILITE MACROS

 

SINISTRO_COORDENADAS.xlsm

Bom dia Marcelo.

Obrigado pela colaboração...é quase isso...

O problema é que essa macro arrendonda a conversão para cima.

Exemplo: -20,8081769 seria 20°48'29.4"S, o que na macro resulta em 21°11'31.0"S, 130 Km de diferença.

Se algum colega souber alterar o código, agradeço imensamente.

Obrigado a todos.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia

a Macro está certa...
-20,8081769 seria 20°48'29.4"S, o que na macro resulta em 21°11'31.0"S, 130 Km de diferença.
este resultado que você citou acima só se fosse coordenadas "positivas" e não negativas como é seu caso.

teste: tire o sinal negativo das suas coordenadas...
 


O truque da filosofia é começar por algo tão simples que ninguém ache digno de nota e terminar por algo tão complexo que ninguém entenda.

16659376348_0bf967577c_s.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, Marcelo Kai disse:

Bom dia

a Macro está certa...
-20,8081769 seria 20°48'29.4"S, o que na macro resulta em 21°11'31.0"S, 130 Km de diferença.
este resultado que você citou acima só se fosse coordenadas "positivas" e não negativas como é seu caso.

teste: tire o sinal negativo das suas coordenadas...
 

Marcelo, concordo plenamente com sua observação, porém essa macro( Convert_Degree) do suporte da Microsoft funciona no hemisfério norte ocidental, onde as coordenadas geográficas decimais são positivas por padrão internacional.

Porém a planilha que trabalho utiliza o Google Maps JavaScript API, que me fornece, por padrão, as coordenadas decimais com o sinal negativo, indicando hemisfério sul ocidental. Como é documento oficial, não posso alterar.

Então teria que ser "automático", pois quando executo a macro do Google a partir da planilha de endereços, já teria que aparecer nas colunas D e E as coordenadas geográficas baseadas nas coordenadas decimais negativas.

Editado por Martti

Compartilhar este post


Link para o post
Compartilhar em outros sites

Alternativa por fórmulas.
Latitude ~~~> =TEXTO(ABS(B2/24);"[h]° mm’ ss'' ")&SE(B2<0;"S";"N")
Longitude ~~~> =TEXTO(ABS(C2/24);"[h]° mm’ ss'' ")&SE(C2<0;"O";"L")

No site abaixo há Calculadora/Conversor de Coordenadas Geográficas  decimal <~~> GMS

http://conversor-de-medidas.com/coordenadas-geograficas

 


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 minutos atrás, osvaldomp disse:

Alternativa por fórmulas.
Latitude ~~~> =TEXTO(ABS(B2/24);"[h]° mm’ ss'' ")&SE(B2<0;"S";"N")
Longitude ~~~> =TEXTO(ABS(C2/24);"[h]° mm’ ss'' ")&SE(C2<0;"O";"L")

No site abaixo há Calculadora/Conversor de Coordenadas Geográficas  decimal <~~> GMS

http://conversor-de-medidas.com/coordenadas-geograficas

 

Bom dia Osvaldo,

Exatamente isso! Muito obrigado.

Aproveitando, como adicionar pelo menos 4 casas decimais no campo segundos?

Exemplo pela sua fórmula: 20° 48’ 29'' S ===> necessidade 20°48'29.4368"

Abraço
 

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, Martti disse:

Aproveitando, como adicionar pelo menos 4 casas decimais no campo segundos?

Exemplo pela sua fórmula: 20° 48’ 29'' S ===> necessidade 20°48'29.4368"

No resultado da fórmula que passei o Excel aceita até 3 casas. Acrescentei a parte em vermelho abaixo.

=TEXTO(ABS(B2/24);"[h]° mm’ ss,000'' ")&SE(B2<0;"S";"N") ~~~> retorna 20° 48’ 29,437'' S

 

Se você precisa de mais casas, aí só por macro ou por UDF. Abaixo a UDF que o Marcelo passou (bah...tchê... :aplauso:  :aperto-de-mao:), alterada para retornar 20° 48' 29,43684'' (com 5 casas decimais; poderá alterar para mais ou para menos ~~~>"#.00000")

Function Convert_Degree(Decimal_Deg) As Variant
  'Set degree to Integer of Argument Passed
  Degrees = Abs(Fix(Decimal_Deg))
  'Set minutes to 60 times the number to the right
  'of the decimal for the variable Decimal_Deg
  Minutes = (Abs(Decimal_Deg) - Degrees) * 60
  'Set seconds to 60 times the number to the right of the
  'decimal for the variable Minute
  Seconds = (Minutes - Int(Minutes)) * 60
  'Returns the Result of degree conversion
 '(for example, 10.46 = 10~ 27  ' 36")
  Convert_Degree = " " & Degrees & "° " & Int(Minutes) & "' " _
      & Format(Seconds, "#.00000") & "''"
End Function

 


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Prezados Marcelo e Osvaldo,

Funcionou perfeitamente! (Y):aplauso:

Mais uma vez muito obrigado pela paciência e atenção em solucionar o meu problema.

Que sirva para outros também.

Grande abraço.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Quer postar a sua dúvida? Cadastre-se pois é rápido e fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

×
×
  • Criar Novo...