Ir para conteúdo

BABOO e KTS 2018 no YouTube Loja online do BABOO

Avoid

Imprimir o menor número e quantas vezes repetiu

Mensagem Recomendada

Faça um Algoritmo para ler 5 números inteiros, em seguida escrever o menor valor lido e quantas vezes este ocorreu nos números lidos.

 

Não estou conseguindo imprimir corretamente a quantidade de vezes que o número repete, dá certo para alguns casos e para outros não. 

 

Citar

Var
   num, menor, n, qtde: inteiro
Inicio
   para n de 1 ate 5 faca
      escreva("DIGITE UM NÚMERO: ")
      leia(num)

      se( n = 1) entao
         menor <- num
      senao
         se(num < menor) entao
            menor<- num
         fimse
         se (menor > qtde)entao
            qtde <- menor
         fimse
      fimse
   fimpara
   escreval()
   escreval("MENOR NÚMERO: ",menor)
   escreval("VEZES QUE O MENOR NUMERO REPETIU", qtde)

Fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Se fosse em C# eu criaria um SortedDictionary<int, int> (ou LIST<int>).

Uma alternativa mais raiz seria usar um array e ir adicionando os itens nela.

Segue a solução raiz (provavelmente tem erros porque nunca escrevi algoritmo e não sei as regras/syntax)

Var
   num, menor, n, qtde: inteiro
   vetor:  array[1 ate 5]
Inicio
   para n de 1 ate 5 faca
      escreva("DIGITE UM NÚMERO: ")
      leia(num)
	  vetor[n] <- num
      se( n = 1) entao
         menor <- num
      senao
         se(num < menor) entao
            menor<-num
         fimse		 
      fimse
   fimpara
   qtde <- 0
   para n de 1 ate 5 faca
      se (vetor[n] = menor) entao
	     qtde <- qtde + 1
	  fimse		 		 
   fimpara
   escreval()
   escreval("MENOR NÚMERO: ",menor)
   escreval("VEZES QUE O MENOR NUMERO REPETIU", qtde)
Fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário


×