Este fórum foi descontinuado. LEIA AQUI e participe da Comunidade BABOO :)

Ir para conteúdo
gabrielpn06

Caracter apos formula

Mensagem Recomendada

Bom dia amigos, sou novo no forum e me perdoem qualquer erro na criacao deste topico,

 

-Tenho uma planilha na qual fiz a seguinte formula: =SE(E(C3>30000,C3<30050),"",SOMA(B4,C3))

 

-Em um modulo, tenho o seguinte  codigo:   Columns("C:C").Select
                                                                              Selection.SpecialCells(xlCellTypeBlanks).Select
                                                                              Selection.Offset(1, 0).EntireRow.Insert

 

Meu problema e que o codigo nao acha as linhas em branco porque a formula gera um caracter, teria algum jeito de definir na formula como "branco" ou no codigo, buscar um "nome" ao inves de "branco"? Desde ja agradeco!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá, Gabriel.

sugestão - disponibilize um arquivo Excel com algumas linhas com dados e com fórmulas na planilha, e também com o código completo no módulo, coloque e  explique na própria planilha qual o resultado desejado


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

×
×
  • Criar Novo...