Este fórum foi descontinuado. LEIA AQUI e participe da Comunidade BABOO :)

Ir para conteúdo
Felipo Vieira

Cálculo (média) com dias, horas e minutos no Excel.

Mensagem Recomendada

Boa noite,

Estou tentando calcular a uma média em dias, horas e minutos (X dia(s), Y hora e W minuto(s)), em um determinado intervalo de células numa planilha de atendimento dos serviços.

A ideia é calcular qual o tempo médio dos atendimentos no formato (X dia(s), Y hora e W minuto(s)), das células que possuem valores calculados através da formula (=SE(MINUTO(MOD(Q2-N2;1))=0;INT(Q2-N2)&" dia(s) e "&HORA(MOD(Q2-N2;1))&" hora(s)";INT(Q2-N2)&" dia(s), "&HORA(MOD(Q2-N2;1))&" hora e "&MINUTO(MOD(Q2-N2;1))&" minuto(s)"))

Exemplo:

Atendimento 1: 39 dia(s), 6 hora e 27 minuto(s)

Atendimento 2: 6 dia(s), 21 hora e 43 minuto(s)

Atendimento 3: 15 dia(s), 17 hora e 50 minuto(s)

Soma total: 61 dia(s), 22 hora(s), 0 minuto(s)

Média: 20 dia(s), 7 hora(s), 0 minuto(s) - > Gostaria de obter esse resultado final (Esse valor que calculei é aproximado não exatamente o valor que vai aparecer calculando a forma correta)

Sendo assim saberei qual o tempo médio de atendimento dos serviços.

Alguém consegue me ajudar?

Obrigado,

Tempos de Atendimento de Serviços.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Veja se esta fórmula matricial pode ajudar (ajuste os intervalos conforme desejado):

=MÉDIA(D2:D16-A2:A16)

obs.
1. para inserir a fórmula como matricial ~~~> cole a fórmula em uma célula vazia, em seguida aperte F2 e em seguida aperte juntas Ctrl+Shift+Enter
2. após, formate a célula ~~~> Personalizado / dd "dias" hh "horas" mm "minutos"


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

×
×
  • Criar Novo...