Este fórum foi descontinuado. LEIA AQUI e participe da Comunidade BABOO :)

A área de Remoção de Malwares está aberta na Comunidade BABOO. LEIA AQUI

Ir para conteúdo
Owieh da silva

RESPONDIDO Formula de Excel

Mensagem Recomendada

Olá, gostaria de criar uma formula que copie os números de uma coluna repetindo 11 vezes, na segunda coluna, cada numero da primeira. Outra formula que procure um numero em uma coluna e copie o numero da outra coluna que está na mesma linha. É possível?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Na figura "sem titulo1" eu gostaria de copiar a coluna "id" da tabela da esquerda e repetir 11 vezes cada id na segunda coluna da tabela da direita. Mais abaixo no arquivo da tabela da direita você encontra a tabela mostrada na figura "sem titulo2" onde quero copiar a primeira coluna "id" e repetir na tabela da direita da figura "sem titulo2".

Sem título.jpg

Sem título2.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 08/03/2018 at 11:06 AM, osvaldomp disse:

Disponibilize uma amostra do seu arquivo Excel com alguns dados e coloque na própria planilha os resultados desejados.

Figuras, prints, imagens, fotos, captura de tela, ... não servem!


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Considerei as duas planilhas em um só arquivo. Se depois você precisar salvar a planilha com as fórmulas em um arquivo separado basta Copiar / Colar Especial Valores para substituir as fórmulas pelo seus respectivos valores.

cole a fórmula abaixo em B2 da planilha 0 e arraste para baixo

=ÍNDICE(rel_produto_1!A:A;INT((LINS(A$1:A1)-1)/11)+10)

Se precisar repetir os dados de outras colunas também, substitua A:A pela coluna desejada: B:B ou C:C, ...


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

×
×
  • Criar Novo...