Este fórum ficará ativo até 15/Jun/2019. LEIA AQUI.

Ir para conteúdo
  • Cadastre-se
Luna Duarte

RESPONDIDO EXCEL -Análise de Diferença de Preço

Mensagem Recomendada

Boa tarde,

Estou trabalhando numa planilha de preço ANUAL , e preciso saber se houve reajuste  de preço no ano  ( tanto para maior ou para menor )

preciso saber o segundo valor praticado diferente do atual vendido.

segue abaixo exemplo da minha planilha :
EX  Na segunda linha temos o caso que o produto  X foi vendido pela ultima vez por (2,33 em fev/2018 , porem antes era vendido no preço de 2,18 em set/2017. ( gostaria de uma formula que buscasse essa diferença,  quando o valor da venda fosse alterado desconsiderando os valores repetidos praticado.

1.jpg.b2e4eee28fb30f44fce78a4f0353da1d.jpg,
 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Experimente a fórmula matricial abaixo em M2.

=ÍNDICE(C2:K2;CORRESP(MÁXIMO(SE(C2:K2<>PROC(2;1/(C2:K2>0);C2:K2);C2:K2));C2:K2;0))

obs. por tratar-se de fórmula matricial, após colar a fórmula na célula M2 aperte F2 e em seguida aperte juntas Ctrl+Shift+Enter e em seguida arraste para baixo.


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Luna Duarte, Bom Dia.

O colega osvaldomp fez uma otina formula, mas eu vi que na coluna N você quer o ultimo valor digitado, então coloca esta formula na coluna N2 a araste para baixo, ira mostrar o ultimo valor

=PROC(2;1/(C2:K2<>0);C2:K2)

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Se você Visitante Também gostou e foi útil pode clique no coração

Decio

 


 

 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Osvaldo, muito bom..

Porem me deparo com o seguinte problema, por se tratar de uma venda e algumas ações de preço, vi que você utilizou a formula máximo ( que pegara o maior valor aplicado na linha ) e se  eu tivesse faturado anteriormente um valor maior  a formula não daria certo . :(

segue exemplo:

1.JPG.d2780aa80bfb7d60e6016ee42984495b.JPGPasta1 (1).xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Experimente esta. É matricial também.

=ÍNDICE(C2:K2;MAIOR(SE(C2:K2>0;SE(C2:K2<>N2;COLUNA(C2:K2)-COLUNA(C2)+1));1))


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite Luna

Deu certo sim, é que em alguns Excel a função COLUNA tem que sr substituída por COL

Fica assim:

=ÍNDICE(C2:K2;MAIOR(SE(C2:K2>0;SE(C2:K2<>N2;COL(C2:K2)-COL(C2)+1));1)) 

Não se esqueça do CTRL+SHIFT+ENTER

Se foi útil, clique no coração da resposta do Osvaldo e na minha.

[]s

  • 1

Patropi - Moderador

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Quer postar a sua dúvida? Cadastre-se pois é rápido e fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

×
×
  • Criar Novo...