CONHEÇA o BABOO PRO e a Comunidade BABOO que substituirão o site BABOO e esse fórum

Ir para conteúdo
  • Cadastre-se

Mensagem Recomendada

Bom dia galera. Primeiramente gostaria de agradecer ao Osvaldo pele excelente ajuda que me deu aqui no fórum, segundo gostaria de fazer uma pergunta um pouco mais complexa: gostaria de criar um intervalo dinâmico para a função mult, pois minha tabela de dados está ficando muito pesada, e toda vez que insere ou apaga um valor ela demora muito. Isso ocorreu principalmente após inserir fórmulas matriciais para a função "mult" (função multiplicação, que a propósito possui dentro dela 2 funções "se"). Conforme o Osvaldo disse, para isso (a lentidão) não ocorrer, deve-se criar um intervalo dinâmico. Pesquisei e consegui compreender a fórmula desloc, porém está dando um nó danado na minha cabeça e não estou conseguindo implementar o intervalo dinâmico na fórmula. Alguém poderia me ajudar? Em anexo a planilha que estou colocando a fórmula. Ela está leve e não apresenta lentidão, mas pq retirei muitos outros dados para apenas deixar o essencial para a dúvida, mas com todos os dados ela fica lenta. A função mult está na aba anual, ela pega as taxas mês a mês e multiplica, desde que esteja no ano.

patrimonio-teste.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

1. Insira os Intervalos Dinâmicos Nomeados conforme a tabela abaixo (obs. a quantidade de linhas resultante para todos os intervalos nomeados será obtida pelas fórmulas com base nas linhas preenchidas na coluna C, a partir de C4, da planilha "$ CONSOLIDADO $", que no seu exemplo é de 4 linhas)
nome ~~~> fórmula
aço ~~~> =DESLOC('$ CONSOLIDADO $'!$L$4;0;0;CONT.VALORES('$ CONSOLIDADO $'!$C:$C)-2;1)
ano ~~~> =DESLOC('$ CONSOLIDADO $'!$A$4;0;0;CONT.VALORES('$ CONSOLIDADO $'!$C:$C)-2;1)
cri ~~~> =DESLOC('$ CONSOLIDADO $'!$O$4;0;0;CONT.VALORES('$ CONSOLIDADO $'!$C:$C)-2;1)
fii ~~~> =DESLOC('$ CONSOLIDADO $'!$R$4;0;0;CONT.VALORES('$ CONSOLIDADO $'!$C:$C)-2;1)
pou ~~~> =DESLOC('$ CONSOLIDADO $'!$U$4;0;0;CONT.VALORES('$ CONSOLIDADO $'!$C:$C)-2;1)
res ~~~> =DESLOC('$ CONSOLIDADO $'!$AA$4;0;0;CONT.VALORES('$ CONSOLIDADO $'!$C:$C)-2;1)
rez ~~~> =DESLOC('$ CONSOLIDADO $'!$Z$4;0;0;CONT.VALORES('$ CONSOLIDADO $'!$C:$C)-2;1)
tes ~~~> =DESLOC('$ CONSOLIDADO $'!$X$4;0;0;CONT.VALORES('$ CONSOLIDADO $'!$C:$C)-2;1)


2. Insira na planilha "ANUAL" as novas fórmulas matriciais, conforme a tabela abaixo (obs. essas fórmulas já contém os Intervalos Nomeados conforme a tabela acima)
célula ~~~> fórmula
B4 ~~~> =PRODUTO(SE(ano=A4;SE(aço<>"";aço)))-1
C4 ~~~> =PRODUTO(SE(ano=A4;SE(cri<>"";cri)))-1
D4 ~~~> =PRODUTO(SE(ano=A4;SE(fii<>"";fii)))-1
E4 ~~~> =PRODUTO(SE(ano=A4;SE(tes<>"";tes)))-1
F4 ~~~> =PRODUTO(SE(ano=A4;SE(pou<>"";pou)))-1
G4 ~~~> =PRODUTO(SE(ano=A4;SE(res<>"";res)))-1

H4 ~~~> =SOMASE(ano;A4;rez) ~~~> esta é a única fórmula não matricial


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Quer postar a sua dúvida? Cadastre-se pois é rápido e fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

×
×
  • Criar Novo...