Este fórum foi descontinuado. LEIA AQUI e participe da Comunidade BABOO :)

Ir para conteúdo
Fabio Junior

EXCEL - Ajuda com formula para exibir resultados de acordo com periodo

Mensagem Recomendada

Amigos,

Estou tentando criar uma planilha que possui duas abas uma que realiza os cadastros e em outra aba que mostra o que foi cadastrado de acordo com o período inicial e final que for escolhido para impressão.

Poderiam me ajudar como posso fazer para exibir os resultados de acordo com a data utilizando formula. 

Em anexo, planilha de exemplo.

 

Muito obrigado!

 

 

Relatorio.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Fabio

Confere se é desta forma que desejas

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda
 

Decio

 

Relatorio Decio.xlsx


 

 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Deciog

Obrigado por sua disposição em ajudar, era isso que estava pensando. Vi que a formula que você criou é matricial. Uma duvida no caso o LIN() e do COL() no final da formula estarem referenciando a aba que mostra os resultados teria algum problema?

Mais uma vez muito obrigado!

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Fabio, Bom DIa.

Esta formula LIN(CADASTRO!$A$2:$A$9)

Esta com referencia a aba porque quando você aumentar linha nela também esta formula tem que ser aumentada, se não fizer referencia você tem que lembrar de aumenta ela LIN(A$2:$A$9), entendeu.

No caso LIN(A1));COL(A1), o primeiro LIN é o K da formula MENOR e o segundo COL é numero da coluna na matriz, este não precisa ser aumentado pois quando arrastar a formula ela aumenta automaticamente, entendeu.

Se minha resposta foi útil, clique no coração é uma forma de agradecimento da ajuda

Decio

 


 

 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 25/07/2018 at 4:07 PM, Fabio Junior disse:

@Deciog

... era isso que estava pensando.
Segue abaixo alternativa, caso sejam preenchidas as linhas 10, 11, 12, ... da planilha CADASTRO elas serão replicadas na planilha RELATORIO. A fórmula retornará até a linha 100 da planilha CADASTRO, e não somente até a linha 12.

cole na planilha RELATORIO:
em G1 para retornar a quantidade de registros que se enquadram no critério, será utilizada na segunda fórmula abaixo

=SOMARPRODUTO((CADASTRO!A2:A100>=B3)*(CADASTRO!A2:A100<=E3))
em seguida cole a fórmula matricial abaixo em A9 ~~~> após colar a fórmula na célula aperte F2 e em seguida aperte juntas Ctrl+Shift+Enter, em seguida arraste até H9 e em seguida arraste a seleção para baixo
=SE(LINS(A$2:A2)>$G$1;"";ÍNDICE(CADASTRO!A$2:A$100;MENOR(SE((CADASTRO!$A$2:$A$100>=$B$3)*(CADASTRO!$A$2:$A$100<=$E$3);LIN(A$2:A$100)-1);LINS(A$2:A2))))


Uma duvida no caso o LIN() e do COL() no final da formula estarem referenciando a aba que mostra os resultados teria algum problema?
Todos os exemplos de comandos abaixo retornam 4, pois se referem ao número da linha. Então a referência à coluna não interfere, bem como a referência à planilha também não. Ou seja, a referência à coluna pode ser qualquer e a referência à planilha é desnecessária.
=LIN(B4)
=LIN(M4)
=LIN(CADASTRO!B4)
=LIN(RELATORIO!M4)


Todos os exemplos de comandos abaixo retornam 1, pois se referem à posição da coluna na planilha. Então a referência à linha não interfere, bem como a referência à planilha também não. Ou seja, a referência à linha pode ser qualquer e a referência à planilha é desnecessária.
=COL(A1)
=COL(A35)
=COL(CADASTRO!A1)
=COL(RELATORIO!A35)

Todos os exemplos de comandos abaixo, se aplicados em fórmula matricial, retornam a seguinte matriz: {2;3;4;5;6;7;8;9}. De forma análoga ao primeiro exemplo acima esses comandos fazem referência à linha, assim a referência à coluna não interfere e a referência à planilha é desnecessária.
=LIN(A2:A9)
=LIN(K2:K9)
=LIN(CADASTRO!A2:A9)
=LIN(RELATORIO!K2:K9)

 

 

 


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Fabio, uma tentativa: cole a fórmula em uma linha vazia assim você poderá visualizar a fórmula toda.

Ao receber a mensagem de erro clique em ok e insira um apóstrofo antes do sinal de igual no início da fórmula, dessa forma a fórmula será inserida como texto e não como fórmula. Em seguida compare cada caracter com a fórmula que está aqui no fórum, pois ao copiar/colar fórmulas daqui às vezes essa operação carrega "sujeira" e introduz espaços ou outros caracteres e aí a fórmula fica contaminada.


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

×
×
  • Criar Novo...