CONHEÇA o BABOO PRO e a Comunidade BABOO que substituirão o site BABOO e esse fórum

Ir para conteúdo
  • Cadastre-se
Michele25

FUNÇÃO SE E com erro

Mensagem Recomendada

Galera me ajudem eu tenho a seguinte situação:

GRUPO ASSUNTO TOTAL HORAS ATENDIMENTO
TESTE DE PASSAGEM 1 DIA 08:00:00
INSTALAÇÃO 1 DIA 05:00:00
TESTE DE PASSAGEM ¹/² Dia 03:00:00

Eu preciso criar uma função na qual:

Se o GRUPO for Teste de Passagem e tiver o tempo acima de 4h; o campo assunto deve retornar 1 Dia

Se o GRUPO for Teste de Passagem e tiver o tempo abaixo de 4h; o campo assunto deve retornar ¹/² Dia

Se o GRUPO for INSTALAÇÃO, então o campo assunto deve retornar Instalação

Eu criei a seguinte fórmula:

=SE(E(A2="TESTE DE PASSAGEM";C2>TEMPO(04;00;00);"1 DIA";SE(E(A2="TESTE DE PASSAGEM";C2=<TEMPO(04;00;00));"¹/²DIA";"INSTALAÇÃO")))

Apresenta o erro: Encontramos um problema nesta fórmula.

Criei uma outra fórmula invertida:

=SE(A2="INSTALAÇÃO";"INSTALAÇÃO";SE(E(A2="TESTE DE PASSAGEM";C2<=TEMPO(04;00;00));"1 DIA";"¹/²DIA"))

Apresenta o erro: Este valor não corresponde às restrições de validação de dados definidas para está célula

Alguém poderia me auxiliar na criação desta fórmula?

Desde já obrigada

Compartilhar este post


Link para o post
Compartilhar em outros sites

Experimente:

=SE(E(A2="TESTE DE PASSAGEM";C2>"4:00"+0);"1 DIA";SE(E(A2="TESTE DE PASSAGEM";C2<="4:00"+0);"1/2 DIA";"INSTALAÇÃO"))


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Osvaldo,

Obrigada pelo retorno, porém apresenta erro: Este valor não corresponde às restrições de validação de dados definidas para está célula.

Compartilhar este post


Link para o post
Compartilhar em outros sites

É preciso remover a Validação de Dados do intervalo em que você vai colocar as fórmulas.

selecione o intervalo / menu Dados / Validação de Dados / Validação de Dados / Limpar tudo / OK


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Estranho, pois realmente não há Validação na planilha.

Colei a fórmula que passei em B2, arrastei até B10 e aceitou de boa. Segue o arquivo com a fórmula aplicada. Veja se atende.

Cópia de TESTE DE PASSAGEM_INTALACAO.xlsx


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Quer postar a sua dúvida? Cadastre-se pois é rápido e fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

×
×
  • Criar Novo...