Este fórum foi descontinuado. LEIA AQUI e participe da Comunidade BABOO :)

A área de Remoção de Malwares está aberta na Comunidade BABOO. LEIA AQUI

Ir para conteúdo

Mensagem Recomendada

Bom dia a todos.

Em uma célula qualquer (A1) devo digitar S ou N. Na Condição S, a fórmula existente em uma outra célula (B1), deve parar de calcular e fixar o último resultado calculado. Se a condição for N, a fórmula deve continuar calculando. N pode demorar muito tempo, mas quando digitar S, o resultado em B1 deve ser travado e assim ficar.

Como conseguir isso?

Grato a todos 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá Osvaldo, bom dia.

É uma fórmula que mostra quantos dias estão além ou aquém de uma data específica. No anexo está a situação real.

Parar fórmula.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá, Maurício.

Veja se alguma das soluções abaixo atende.

opção1 - solução via macro
Instale o código abaixo no módulo da planilha, assim:
1. copie o código daqui
2. clique com o direito na guia da planilha de interesse e escolha 'Exibir código'
3. cole o código na janela em branco que vai se abrir
4. feito! 'Alt+Q' para retornar para a planilha e testar

Private Sub Worksheet_Change(ByVal Target As Range)
 If Intersect(Target, [A1,G7]) Is Nothing Or Target.Value = "" Then Exit Sub
 If [A1] = "N" Then [B1] = [G7] - Date
End Sub

opção1 - solução via fórmula
Cole a fórmula abaixo em B1.

=SE(G7="";"";SE(A1="S";B1;SE(A1="N";G7-HOJE())))

obs. como a fórmula acima faz referência a ela própria o Excel exibirá mensagem de Referência Circular. Para inibir a mensagem: Arquivo / Opções / Fórmulas / marque Habilitar cálculo iterativo / OK


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

×
×
  • Criar Novo...