Este fórum foi descontinuado. LEIA AQUI e participe da Comunidade BABOO :)

Ir para conteúdo
Gilliard 123

Criar Macro Excel

Mensagem Recomendada

Bom dia

Estou começando a trabalhar com macro, e preciso fazer algum procedimento para que faça a retirada do valor da célula f12 para a cécula c6 (VALOR)

OBS: eu precisaria se possível que quando eu clica-se em retirada essa operação acima fosse feita, e nessa hora na célula f12 zerasse o valor que esteja nela, sem limpar o formula que tem nessa célula!

Obrigado desde já

204139856_Semttulo.png.ae7fbeddc415bb21978a8b3051aabdfe.png

 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 horas atrás, Gilliard 123 disse:

... fazer algum procedimento para que faça a retirada do valor da célula f12 para a cécula c6 (VALOR)
Para replicar (e não retirar) o valor de F12 em C6 utilize o primeiro código abaixo.

... e nessa hora na célula f12 zerasse o valor que esteja nela, sem limpar o formula que tem nessa célula!
Isso que você quer fazer não é possível com a operação de replicar o valor.
Uma forma de contornar seria alterar a fórmula que está em F12 para ~~~>

=SE(C6<>"";0;ENTRADAS!B1-SAÍDAS!B1)
e utilizar o segundo código abaixo

Sub RetiradaV1()
 [C6] = [F12]
End Sub
Sub RetiradaV2()
 [C6] = "": [C6] = [F12]
End Sub

 


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Cara funcionou, e está quase do jeito que eu queria!!! 

Eu lanço uma entrada e criei uma macro que leva este valor de entrada para outra aba (tipo uma planilha de controle), fiz o mesmo precedimento com as saídas e retirada!

O único problema é que depois que faço uma retirada, devido aquela segunda formula e macro que você me passou, ela zera a celula f12, até aqui tudo certo pois foi o que tinha te pedido, mas, quando eu preciso fazer uma nova entrada, a celula f12 continua zerada!!!

 

Oque eu poço fazer para resolver isso???

Muito obrigado pela ajuda Osvaldo!!!

Compartilhar este post


Link para o post
Compartilhar em outros sites

 

2 horas atrás, Gilliard 123 disse:

Eu lanço uma entrada e criei uma macro que leva este valor de entrada para outra aba (tipo uma planilha de controle), fiz o mesmo precedimento com as saídas e retirada!

Oque eu poço fazer para resolver isso???

Em lugar de utilizar os códigos que eu sugeri, veja a possibilidade de incluir na sua outra macro os comandos para:

1. capturar o valor de F12 e fazer as devidas ações da macro

2. limpar F12 e fazer as demais ações da macro

3. reinserir a fórmula em F12

 


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

1. capturar o valor de F12 e fazer as devidas ações da macro

 2. limpar F12 e fazer as demais ações da macro

3. reinserir a fórmula em F12

Como faço isso???

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Precisamos ver o seu código atual.

Informe também em quais partes do seu código você quer fazer cada uma das três operações que citei no post anterior.


 

Osvaldo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

×
×
  • Criar Novo...